Project

General

Profile

Bug #4959

Alias autocomplete is gone

Added by Chris Buechler over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Target version:
-
Start date:
08/17/2015
Due date:
% Done:

0%

Spent time:
Affected version:
Affected Architecture:

Description

Upon typing in the first letter of an alias, it pops up a list of matching aliases (those starting with that letter), and it narrows down the list as you type. This is completely gone.

Every page that accepts aliases (rules, NAT, etc.) has this now.

History

#1 Updated by Steve Beaver over 1 year ago

  • Assignee set to Steve Beaver

#2 Updated by Steve Beaver over 1 year ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

It's back :)

#3 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Confirmed
  • Assignee changed from Chris Buechler to Steve Beaver

It's better but still not 100%.

On aliases and rules the search results (Or "No search results") are printed near the bottom of the page and it rejects the save saying the alias isn't the proper format for the field.

Sorry for the size of this image but it's the only good way to show both things as they happen

#4 Updated by Steve Beaver over 1 year ago

The problem is not the autocomplete thing, but that the input field is set to "IpAddress" and so does not accept a host name.

That one will take some head scratching. I'll get to it later today.

#5 Updated by Jim Pingle over 1 year ago

OK, there is still the issue of the search results (debug code?) printing out. More apparent when editing an alias set to Network type:

#6 Updated by Steve Beaver over 1 year ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Jim Pingle

Autocomplete has been fixed by hiding the helper text.

Failure to validate will be addressed in a new ticket.

#7 Updated by Steve Beaver over 1 year ago

  • Assignee changed from Jim Pingle to Chris Buechler

#8 Updated by Chris Buechler over 1 year ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF