Project

General

Profile

Bug #5141

vpn_openvpn_server.php tap options missing

Added by Chris Buechler over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
09/15/2015
Due date:
% Done:

100%

Spent time:
Affected version:
2.3
Affected Architecture:

Description

When switching from Device Mode tun to tap on vpn_openvpn_server.php, 4 new fields should show up. "Bridge DHCP", "Bridge Interface", "Server Bridge DHCP Start", "Server Bridge DHCP End". The last 3 are disabled unless "Bridge DHCP" is checked.

Those are completely missing. 2.2.4 example on 172.27.44.105, edit that server instance and see what happens when switching tun->tap

Associated revisions

History

#1 Updated by Steve Beaver over 1 year ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

From the page logic it looks like those input are shown:

if tunneltype == TAP AND if servermode != peer-to-peer

When shown, those inputs are disabled if "bridge DHCP" is not checked.

This behaviors looks to be hte same on 2.2 and 2.3 now.

#2 Updated by Steve Beaver over 1 year ago

  • % Done changed from 0 to 100

#3 Updated by Chris Buechler over 1 year ago

  • Status changed from Feedback to Resolved

fixed

Also available in: Atom PDF