Project

General

Profile

Bug #6664

It's impossible to use HE.NET tunnel iface as a parent for OpenVPN instances

Added by Dmitriy K 7 months ago. Updated 25 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
07/30/2016
Due date:
% Done:

0%

Affected version:
All
Affected Architecture:
All

Description

Setup:
  • HE.NET tunnel iface [for example, WAN_HE]
Steps to reproduce:
  • Create an IPv6 OpenVPN instance on parent iface WAN_HE [for example, OVPN_AMS]
  • Go to dashboard. OVPN_AMS is down.
Expected:
  • OVPN_AMS is up
Actual:
  • "Status -> System Logs -> OpenVPN" has a string "Options error: --local and --nobind don't make sense when used together"
Workaround:
  • Edit /var/etc/openvpn/client?.ovpn file by removing nobind option
  • Restart openvpn service

History

#1 Updated by Dmitriy K 7 months ago

Yet another workaround: Specify a local port instead of empty/0. Looks like $iface_ip is not properly initialized when he.net iface is chosen.

#2 Updated by Jim Pingle 5 months ago

  • Target version changed from 2.3.2_1 to 2.4.0

#3 Updated by Jim Pingle 25 days ago

  • Status changed from New to Resolved
  • Assignee set to Jim Pingle

Also available in: Atom PDF