Project

General

Profile

Bug #7026

filter_logs.inc: parse_firewall_log_line(): Filter logs do not display

Added by Steve Beaver 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Category:
Logging
Target version:
Start date:
12/20/2016
Due date:
% Done:

100%

Affected version:
2.4
Affected Architecture:

Description

There is a problem with the format of the filter logs which is causing src/etc/inc/filter_logs.inc: parse_firewall_log_line() to barf. Several fields it requires are not present in 2.4.

History

#1 Updated by Steve Beaver 3 months ago

2.4 logs:
Dec 1 16:34:41 pfSense filterlog: 61,16777216,,12000,cpsw0,match,block,in,0,bad-hlen=0),0
Dec 1 16:39:10 pfSense filterlog: 61,16777216,,12000,cpsw0,match,block,in,0,bad-hlen=0),0

2.3 logs:
Dec 20 18:35:13 pfSense filterlog: 7,16777216,,1000000105,igb0,match,block,in,6,0x00,0x8d5a9,255,UDP,17,74,fe80::14b3:8a28:e029:4257,ff02::fb,5353,5353,74
Dec 20 18:35:13 pfSense filterlog: 7,16777216,,1000000105,igb0,match,block,in,6,0x00,0x8d5a9,255,UDP,17,226,fe80::14b3:8a28:e029:4257,ff02::fb,5353,5353,226

#2 Updated by Luiz Otavio O Souza 3 months ago

  • Assignee set to Luiz Otavio O Souza

I'll take this one, this happens because of a change on a struct size.

#3 Updated by Jim Pingle 3 months ago

Looks the same as #6919

#4 Updated by Luiz Otavio O Souza 3 months ago

  • Status changed from New to Confirmed

That's right JimP, but seems like we have a regression...

#5 Updated by Luiz Otavio O Souza 3 months ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#6 Updated by Steve Beaver 3 months ago

  • Status changed from Feedback to Resolved

Thanks you Luiz.

Also available in: Atom PDF