Project

General

Profile

Bug #7102

This firewall does not have any interfaces assigned that are capable of using ALTQ traffic shaping for igb interface

Added by Chris Collins 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Shaper
Target version:
Start date:
01/07/2017
Due date:
% Done:

100%

Affected version:
2.4
Affected Architecture:

Description

Is intel i350 interface

According to this url it can be patched to work. Can the patches please be made on the pfsense 2.4 code?

https://forums.freebsd.org/threads/48283/

Associated revisions

Revision fc47d47a
Added by Jim Pingle 2 months ago

Fix a case where the ALTQ capability warning was showing incorrectly. Fixes #7102

History

#1 Updated by Jim Pingle 2 months ago

  • Status changed from New to Duplicate
  • Priority changed from High to Normal

Probably a duplicate of #7066 which appears to be a more general issue.

#2 Updated by Chris Collins 2 months ago

Possibly yes as it seems also broken on realtek.

I tried to move both cables to the reX ports but it seems my re1 port is broken so I tested with just wan on realtek but that wont enable ALTQ either.

I hope this is considered a high priority issue as I think traffic shaping is important on a router.

#3 Updated by Chris Collins 2 months ago

Jim seems it is working, and its a GUI bug.

the command line doesnt give any errors, however I am not 100% sure as the queue's dont appear to be actually working on tests but when I run pfctl -f /tmp/rules.debug there is no errors.

#4 Updated by Jim Pingle 2 months ago

The only place I see this message appear is when a NIC is in use that does NOT have ALTQ support (e.g. lagg, cpsw, etc). I am able to use ALTQ on Realtek interfaces without any problem. There does not appear to be any general problem here that I can see, only what the other ticket already covers.

#5 Updated by Chris Collins 2 months ago

I can confirm 100% now ALTQ is working.

1 - if I apply the rules on cli is no error, if altq was broken it would say so.
2 - in the status - queues page it all looks good.

So the bug is not what I originally said, its a cosmetic issue with the GUI thinking ALTQ has failed when it has not.

#6 Updated by Jim Pingle 2 months ago

  • Status changed from Duplicate to Rejected

Then you'll need to provide a lot more detail about your NICs & the drivers they use (dmesg, ifconfig output, GUI assignments) so we can tell why it is showing up this way.

If you see this message in the GUI, the NIC type is not on our list of those that are capable of using ALTQ.

#7 Updated by Chris Collins 2 months ago

It is a bit of a wow that you have rejected a clear report telling you that there is a misleading message in the GUI.

There isnt much detail to give you, it is not a complex setup.

Two 'igb' interfaces
Two 're' interfaces (which are in a off state).

Those are the only physical interfaces.

There is a virtual opvnc interface.
There is a virtual enc interface
There is lo0
There is pflog and pfsync interfaces

If your code is misdiagnosing if altq is supported on the active WAN and LAN interfaces then it is a bug. It shouldnt be checking other interfaces that are not assigned to LAN and WAN.

igb0 is assigned to wan
igb1 is assigned to lan

here is dmesg, pfsense is an incredible piece of software, it is amazing it works as well as it does, but it is also disappointing you reject a bug report someone has spent the time to write up so quickly.

Copyright (c) 1992-2016 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 11.0-RELEASE-p5 #36 6ff58f929c7(RELENG_2_4): Wed Jan 4 04:44:32 CST 2017
:/builder/ce/tmp/obj/builder/ce/tmp/FreeBSD-src/sys/pfSense amd64
FreeBSD clang version 3.8.0 (tags/RELEASE_380/final 262564) (based on LLVM 3.8.0)
VT: resolution 640x480
CPU: Intel(R) Celeron(R) CPU N3150 @ 1.60GHz (1600.05-MHz K8-class CPU)
Origin="GenuineIntel" Id=0x406c3 Family=0x6 Model=0x4c Stepping=3
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
Features2=0x43d8e3bf<SSE3,PCLMULQDQ,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,MOVBE,POPCNT,TSCDLT,AESNI,RDRAND>
AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>
AMD Features2=0x101<LAHF,Prefetch>
Structured Extended Features=0x2282<TSCADJ,SMEP,ERMS,NFPUSG>
VT-x: PAT,HLT,MTF,PAUSE,EPT,UG,VPID
TSC: P-state invariant, performance statistics
real memory = 4294967296 (4096 MB)
avail memory = 3947810816 (3764 MB)
Event timer "LAPIC" quality 600
ACPI APIC Table: <ALASKA A M I >
WARNING: L1 data cache covers less APIC IDs than a core
0 < 1
FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
FreeBSD/SMP: 1 package(s) x 4 core(s)
ACPI BIOS Warning (bug): 32/64X length mismatch in FADT/Gpe0Block: 128/32 (20160527/tbfadt-650)
ioapic0 <Version 2.0> irqs 0-114 on motherboard
random: entropy device external interface
wlan: mac acl policy registered
kbd0 at kbdmux0
netmap: loaded module
module_register_init: MOD_LOAD (vesa, 0xffffffff8122a980, 0) error 19
random: registering fast source Intel Secure Key RNG
random: fast provider: "Intel Secure Key RNG"
vtvga0: <VT VGA driver> on motherboard
cryptosoft0: <software crypto> on motherboard
padlock0: No ACE support.
acpi0: <ALASKA A M I > on motherboard
acpi0: Power Button (fixed)
unknown: I/O range not supported
cpu0: <ACPI CPU> on acpi0
cpu1: <ACPI CPU> on acpi0
cpu2: <ACPI CPU> on acpi0
cpu3: <ACPI CPU> on acpi0
atrtc0: <AT realtime clock> port 0x70-0x77 on acpi0
atrtc0: Warning: Couldn't map I/O.
Event timer "RTC" frequency 32768 Hz quality 0
attimer0: <AT timer> port 0x40-0x43,0x50-0x53 irq 0 on acpi0
Timecounter "i8254" frequency 1193182 Hz quality 0
Event timer "i8254" frequency 1193182 Hz quality 100
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
vgapci0: <VGA-compatible display> port 0xf000-0xf03f mem 0x80000000-0x80ffffff,0x88000000-0x8fffffff irq 16 at device 2.0 on pci0
vgapci0: Boot video device
ahci0: <AHCI SATA controller> port 0xf060-0xf07f mem 0x81511000-0x815117ff irq 19 at device 19.0 on pci0
ahci0: AHCI v1.31 with 2 6Gbps ports, Port Multiplier not supported
ahcich0: <AHCI channel> at channel 0 on ahci0
ahcich1: <AHCI channel> at channel 1 on ahci0
xhci0: <XHCI (generic) USB 3.0 controller> mem 0x81500000-0x8150ffff irq 20 at device 20.0 on pci0
xhci0: 32 bytes context size, 64-bit DMA
usbus0 on xhci0
pci0: <encrypt/decrypt> at device 26.0 (no driver attached)
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci1: <ACPI PCI bus> on pcib1
re0: <RealTek 8168/8111 B/C/CP/D/DP/E/F/G PCIe Gigabit Ethernet> port 0xe000-0xe0ff mem 0x90104000-0x90104fff,0x90100000-0x90103fff irq 16 at device 0.0 on pci1
re0: Using 1 MSI-X message
re0: Chip rev. 0x2c800000
re0: MAC rev. 0x00100000
miibus0: <MII bus> on re0
rgephy0: <RTL8169S/8110S/8211 1000BASE-T media interface> PHY 1 on miibus0
rgephy0: none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
re0: Using defaults for TSO: 65518/35/2048
re0: Ethernet address: 08:62:66:96:af:e0
re0: netmap queues/slots: TX 1/256, RX 1/256
pcib2: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
pcib2: [GIANT-LOCKED]
pci2: <ACPI PCI bus> on pcib2
re1: <RealTek 8168/8111 B/C/CP/D/DP/E/F/G PCIe Gigabit Ethernet> port 0xd000-0xd0ff mem 0x90004000-0x90004fff,0x90000000-0x90003fff irq 17 at device 0.0 on pci2
re1: Using 1 MSI-X message
re1: Chip rev. 0x2c800000
re1: MAC rev. 0x00100000
miibus1: <MII bus> on re1
rgephy1: <RTL8169S/8110S/8211 1000BASE-T media interface> PHY 1 on miibus1
rgephy1: none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
re1: Using defaults for TSO: 65518/35/2048
re1: Ethernet address: 00:e0:4c:68:55:af
re1: netmap queues/slots: TX 1/256, RX 1/256
pcib3: <ACPI PCI-PCI bridge> irq 18 at device 28.2 on pci0
pci3: <ACPI PCI bus> on pcib3
igb0: <Intel(R) PRO/1000 Network Connection, Version - 2.5.3-k> port 0xc020-0xc03f mem 0x81380000-0x813fffff,0x81404000-0x81407fff irq 18 at device 0.0 on pci3
igb0: Using MSIX interrupts with 2 vectors
igb0: Ethernet address: 00:30:18:c3:d0:e5
igb0: netmap queues/slots: TX 1/4096, RX 1/4096
igb1: <Intel(R) PRO/1000 Network Connection, Version - 2.5.3-k> port 0xc000-0xc01f mem 0x81280000-0x812fffff,0x81400000-0x81403fff irq 19 at device 0.1 on pci3
igb1: Using MSIX interrupts with 2 vectors
igb1: Ethernet address: 00:30:18:c3:d0:e6
igb1: netmap queues/slots: TX 1/4096, RX 1/4096
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
acpi_button0: <Sleep Button> on acpi0
acpi_tz0: <Thermal Zone> on acpi0
ppc0: cannot reserve I/O port range
est0: <Enhanced SpeedStep Frequency Control> on cpu0
est1: <Enhanced SpeedStep Frequency Control> on cpu1
est2: <Enhanced SpeedStep Frequency Control> on cpu2
est3: <Enhanced SpeedStep Frequency Control> on cpu3
Timecounters tick every 1.000 msec
nvme cam probe device init
usbus0: 5.0Gbps Super Speed USB v3.0
ugen0.1: <0x8086> at usbus0
uhub0: <0x8086 XHCI root HUB, class 9/0, rev 3.00/1.00, addr 1> on usbus0
uhub0: 13 ports with 13 removable, self powered
ugen0.2: <vendor 0x1997> at usbus0
ukbd0: <vendor 0x1997 Mini Keyboard, class 0/0, rev 1.10/20.12, addr 1> on usbus0
kbd1 at ukbd0
ugen0.3: <vendor 0x05e3> at usbus0
uhub1: <vendor 0x05e3 USB2.0 Hub, class 9/0, rev 2.00/85.36, addr 2> on usbus0
uhub1: 4 ports with 4 removable, self powered
ada0 at ahcich0 bus 0 scbus0 target 0 lun 0
ada0: <KINGSTON SMS200S360G 608ABBF0> ATA8-ACS SATA 3.x device
ada0: Serial Number 50026B72630613B0
ada0: 600.000MB/s transfers (SATA 3.x, UDMA6, PIO 512bytes)
ada0: Command Queueing enabled
ada0: 57241MB (117231408 512 byte sectors)
SMP: AP CPU #2 Launched!
SMP: AP CPU #1 Launched!
SMP: AP CPU #3 Launched!
Timecounter "TSC" frequency 1600052920 Hz quality 1000
Trying to mount root from ufs:/dev/ufsid/583833e4356ffdb6 [rw,noatime]...
random: unblocking device.
padlock0: No ACE support.
aesni0: <AES-CBC,AES-XTS,AES-GCM,AES-ICM> on motherboard
coretemp0: <CPU On-Die Thermal Sensors> on cpu0
coretemp1: <CPU On-Die Thermal Sensors> on cpu1
coretemp2: <CPU On-Die Thermal Sensors> on cpu2
coretemp3: <CPU On-Die Thermal Sensors> on cpu3
igb0: link state changed to UP
tun1: changing name to 'ovpnc1'
pflog0: promiscuous mode enabled
ovpnc1: link state changed to UP
igb1: link state changed to UP
re0: link state changed to DOWN
re1: link state changed to DOWN

#8 Updated by Jim Pingle 2 months ago

The ticket was rejected because I attempted the same configuration and found no problem on current 2.4 snapshots. I have tested units with igb WAN/LAN and re WAN/LAN and both worked fine with ALTQ and produced no errors.

The bug report, as written, was lacking any relevant information. No details about the interfaces, not even what page displayed the error. We require bug reports to contain at least enough information to replicate the problem and supporting details. We also recommend posting on the forum first to gather information and thoughts and perhaps get additional confirmation.

Additionally, your snapshot is 4 days old. Any bug report made against a development version must use a current snapshot.

#9 Updated by Jim Pingle 2 months ago

  • Tracker changed from Feature to Bug
  • Project changed from pfSense Packages to pfSense
  • Category set to Traffic Shaper
  • Status changed from Rejected to Assigned
  • Assignee set to Jim Pingle
  • Target version set to 2.4.0
  • Affected version set to 2.4

I found a way to reproduce this one, it's a different problem. If all of the ALTQ-capable interfaces were assigned and using ATLQ, the error still appeared. I have a fix pending.

#10 Updated by Jim Pingle 2 months ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

#11 Updated by Chris Collins 2 months ago

ok thanks for taking the time to find the cause.

I respect you want to sort of filter things out on the forum first, and as such in future will not post on here which I said in another ticket also, then if you decide if something I post on the forum is a bug then you can go from there.

I was harsh in my reply on the other ticket also and I apologise for that as it wasnt you that called me a liar but someone else.

I am still watching this ticket so if you do a fix and need me to test after I will be emailed the update.

#12 Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Resolved

Fixed

#13 Updated by Chris Collins 2 months ago

do you want me to update my snapshot and test?

Also available in: Atom PDF