Project

General

Profile

Bug #7129

system_advanced_notifications.php - Cannot save settting - growl passwords must match

Added by Kill Bill 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
01/17/2017
Due date:
% Done:

0%

Affected version:
2.3.x
Affected Architecture:
All

Description

- I never enabled/configured/touched this (IOW, this should certainly default to disabled, I'd imagine the number of users is very close to zero)
- I do not wish to configure anything there, I merely ticked a Disable SMTP notifications checkbox, but it's a no go. Cannot Save

Associated revisions

Revision 06f7d60e
Added by Doktor Notor 2 months ago

Do not nag people about passwords mismatch when growl is disabled (Bug #7129)

These fields tend to get "helpfully" pre-filled with random crap by built-in browser password managers or extensions such as LastPass. No need to bother people with these when the feature is disabled.

Revision 3988cfa7
Added by Doktor Notor 2 months ago

Do not nag people about passwords mismatch when SMTP notifications are disabled (Bug #7129)

Revision 83ddceca
Added by Doktor Notor 2 months ago

Do not nag people about passwords mismatch when growl is disabled (Bug #7129)

These fields tend to get "helpfully" pre-filled with random crap by built-in browser password managers or extensions such as LastPass. No need to bother people with these when the feature is disabled.
(cherry picked from commit 06f7d60e9de1dde2886dd84009e3986678eaa27e)

Revision ab34907e
Added by Doktor Notor 2 months ago

Do not nag people about passwords mismatch when SMTP notifications are disabled (Bug #7129)
(cherry picked from commit 3988cfa7d281370500a7f58cb5f73f28a931f0ae)

History

#1 Updated by Kill Bill 2 months ago

Clearly caused by password management in browsers (or password management extensions such as LastPass) helpfully pre-filling in the fields with "something". I guess not validating passwords match unless the feature is enabled would be the best we can get here.

https://github.com/pfsense/pfsense/pull/3393

#2 Updated by Kill Bill 2 months ago

Merged, can be closed. Thanks.

#3 Updated by Renato Botelho 2 months ago

  • Status changed from New to Resolved

#4 Updated by Jim Pingle about 2 months ago

  • Target version changed from 2.4.0 to 2.3.3

Also available in: Atom PDF