Project

General

Profile

Bug #7194

CARP/IP Aliases under same subnet not synced correctly

Added by James Webb 17 days ago. Updated 17 days ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
CARP
Target version:
Start date:
02/02/2017
Due date:
% Done:

0%

Affected version:
Affected Architecture:

Description

If you set a CARP VIP e.g. an address on the WAN subnet xxx.xxx.xxx.xx1/28. Then set another address, be it another CARP or IP Alias to the above CARP under the same subnet e.g. xxx.xxx.xxx.xx2/28. When a failover occurs the CARP/IP Alias under the CARP VIP (i.e. The .xx2/28) doesn't transfer properly. This can be tested by going to the Ping page and trying to contact the primary WAN IP from the .xx2/28 CARP/IP Alias VIP (no route). This can be resolved on the secondary (now acting as master) by going to the Firewall->VIPs->xxx.xxx.xxx.xx2/28 then hitting Save. Then everything works.

Can this be resolved?

James

History

#1 Updated by Jim Pingle 17 days ago

  • Status changed from New to Rejected

I can't reproduce this on a current 2.4 snapshot. Additional addresses fail over all at once as expected.

Also available in: Atom PDF