Project

General

Profile

Actions

Bug #10183

closed

diag_packet_capture.php: Capture for 'pfsync' fails

Added by Jim Pingle almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Packet Capture
Target version:
Start date:
01/13/2020
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:
All

Description

On diag_packet_capture.php, attempting to capture traffic fails when the protocol is set to 'pfsync'.

This happens on 2.4.5 and 2.5.0, with an error similar to:

Warning: filesize(): stat failed for /root/packetcapture.cap in /usr/local/www/diag_packet_capture.php on line 537

It appears to fail silently on 2.4.4-p3 as well. The command it forms yields a syntax error when attempted directly at the command line.

Looks like it needs a protocol fixup similar to ospf/carp.

To me, I'm working on a fix.

Actions #1

Updated by Jim Pingle almost 2 years ago

  • Status changed from Confirmed to In Progress
Actions #2

Updated by Jim Pingle almost 2 years ago

  • Category changed from Diagnostics to Packet Capture
Actions #3

Updated by Jim Pingle almost 2 years ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Raul Ramos almost 2 years ago

With the combination Address family: IPv4 and ARP protocol i have the same warning

Actions #5

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to In Progress
Actions #6

Updated by Jim Pingle almost 2 years ago

  • Status changed from In Progress to Feedback
Actions #7

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved

Works fine on 2.4.5.a.20200114.0923

Actions

Also available in: Atom PDF