Project

General

Profile

Feature #10256

Add support for IPv6 to No-IP Dynamic DNS

Added by Csoban Kesmarki 9 months ago. Updated 23 days ago.

Status:
Resolved
Priority:
Low
Category:
Dynamic DNS
Target version:
Start date:
02/12/2020
Due date:
% Done:

100%

Estimated time:

Description

Suggesting an update to the /etc/inc/services.inc and /etc/int/dyndns.class to support IPv6 Dynamic DNS update for noip.com.
It only make sense as some ISP are providing new IPv6 address in every PPPoE re-connection. (e.g. Telekom Hungary)
Posting suggested patch. Tested, working.

NoIPv6.patch (4.39 KB) NoIPv6.patch Csoban Kesmarki, 02/12/2020 12:33 PM

Associated revisions

History

#1 Updated by Jim Pingle 9 months ago

  • Tracker changed from Bug to Feature
  • Subject changed from Missing No-IP IPv6 support from Dynamic DNS service to Add support for IPv6 to No-IP Dynamic DNS
  • Affected Version deleted (2.4.4-p3)
  • Affected Architecture deleted (All)

Changed from Bug to Feature Request as it's not a bug, but a missing feature. Corrected subject to match.

Can you submit that change as a pull request on Github?

https://docs.netgate.com/pfsense/en/latest/development/submitting-a-pull-request-via-github.html

#2 Updated by Jim Pingle 9 months ago

  • Status changed from New to Pull Request Review

#4 Updated by Renato Botelho 8 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee changed from Csoban Kesmarki to Renato Botelho
  • Target version changed from Future to 2.5.0
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#5 Updated by Steve Beaver 23 days ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF