Project

General

Profile

Bug #10281

I can unassign interface even if it is used in FRR OSPF

Added by Constantine Kormashev 9 months ago. Updated 9 months ago.

Status:
Not a Bug
Priority:
Low
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
02/23/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

There was IPsec VTI tunnel with assigned interface. The interface was used in FRR OSPF settings as OSPF interface. If I remove interface from assigned it still exists in FRR OSPF settings. No warnings during unassigning, I could only find the issue when tried to disable IPsec VTI entry, I got warning: Cannot disable a Phase 1 with a child Phase 2 while the interface is assigned. Remove the interface assignment before disabling this P2. But there was not assigned interface related to this IPsec entry, interface was deleted, excepting previously assigned interface is still in FRR OSPF settings.
The warning is not easy to figure out if you do not know/remember where else related interface was used. I guess we need warning for unassigning interface if one is used in FRR, or delete it from FRR config.

History

#1 Updated by Jim Pingle 9 months ago

  • Category set to Interfaces
  • Status changed from New to Not a Bug

It's not a bug in FRR. There is no way for the base system to know that a package is using an interface, and no way for a package to prevent a base system action like that.

#2 Updated by Viktor Gurov 9 months ago

from https://redmine.pfsense.org/issues/9789:
There is no elegant or simple way for notifying a running package that an interface is being removed or unassigned within the pfSense GUI.
It is probably better to expect the user to understand the potential ramifications of removing or unassigning an interface that may also be in active use by a package.

Also available in: Atom PDF