Project

General

Profile

Bug #1074

Monitor IP Gateway ignored

Added by Danny Bogaards over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Gateways
Target version:
Start date:
12/06/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

If I set an alternative 'Monitor IP' for a gateway, this is ignored. Is is stored in config.xml though!

config.xml:

<gateway_item>
        <interface>wan</interface>
        <gateway>dynamic</gateway>
        <name>GW_WAN</name>
        <weight>1</weight>
        <descr><![CDATA[Interfacewandynamic gateway]]></descr>
        <monitor>217.115.204.200</monitor>
</gateway_item>


apinger.conf:
target "192.168.0.1" {
        description "GW_WAN" 
        srcip "192.168.0.100" 
        alarms override "loss","delay","down";
        rrd file "/var/db/rrd/GW_WAN-quality.rrd" 
}

192.168.0.1 is the gateway of GW_WAN (DHCP). Tried reboot.

ALIX board: 2.0-BETA4 (i386), built on Sun Dec 5 07:23:23 EST 2010

1.png (33.7 KB) 1.png gateway screenshots webinterfac Danny Bogaards, 12/06/2010 06:13 AM
config.xml (60.5 KB) config.xml Danny Bogaards, 12/06/2010 07:24 AM
apinger.conf (2.37 KB) apinger.conf Danny Bogaards, 12/06/2010 07:24 AM
system.log (500 KB) system.log Danny Bogaards, 12/06/2010 07:24 AM

History

#1 Updated by Ermal Luçi over 8 years ago

Can you please paste some screenshots here of your gateways?

#2 Updated by Danny Bogaards over 8 years ago

Hereby I upload some screenshots.

#3 Updated by Ermal Luçi over 8 years ago

I cannot reproduce this on latest snapshots.
Please post even your system log and your full config.xml otherwise this will be closed.

#4 Updated by Danny Bogaards over 8 years ago

system log, full xml and apinger.conf posted

#5 Updated by Ermal Luçi over 8 years ago

  • Status changed from New to Closed

Remove these two stale entries from your config

<gateway_item>
1946    
                        <gateway>dynamic</gateway>
1947    
                        <descr><![CDATA[Interface opt1 dynamic gateway]]></descr>
1948    
                        <name>GW_OPT1</name>
1949    
                        <interface>opt1</interface>
1950    
                </gateway_item>
1951    
                <gateway_item>
1952    
                        <gateway>dynamic</gateway>
1953    
                        <descr><![CDATA[Interfacewandynamic gateway]]></descr>
1954    
                        <name>GW_WAN</name>
1955    
                        <interface>wan</interface>
1956    
                </gateway_item>

Seems like a mangled config to me.

Also available in: Atom PDF