Project

General

Profile

Bug #11259

pfBlockerNG-devel fails to update all IP addresses for ASN using IPv4 Source Definitions

Added by P L about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
pfBlockerNG
Target version:
-
Start date:
01/18/2021
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.5-p1
Affected Architecture:

Description

pfBlockerNG-devel v3.0.0_8

pfBlockerNG-devel fails to update all IP addresses for ASN using IPv4 Source Definitions

Setup ASN using pfBlockerNG-devel --> IP --> IPv4 (and v6?) --> IPv4 Source Definitions --> Format: ASN

Selected Facebook ASN: AS32934. Updated pfBlockerNG. Fails to load 31.13.71.50, which is part of AS32934. It loads other IP addresses. It appears to only load a limited number?

When using IPv4 Custom_List, the IP address above does load with AS32934.

History

#1 Updated by P L about 1 month ago

I may not be able to reproduce this bug now.

#2 Updated by Viktor Gurov about 1 month ago

  • Status changed from New to Closed

31.13.71.50 is in
https://api.bgpview.io/asn/32934/prefixes:

{"prefix":"31.13.71.0\/24","ip":"31.13.71.0","cidr":24,"roa_status":"None","name":"IE-FACEBOOK-20110418","description":"Facebook Ireland Ltd","country_code":"IE","parent":{"prefix":"31.13.64.0\/18","ip":"31.13.64.0","cidr":18,"rir_name":"RIPE","allocation_status":"unknown"}},

it looks like there was an issue with bgpview.io db

Also available in: Atom PDF