Project

General

Profile

Bug #11337

Interface column empty in list of GIF tunnels when using IP Alias on CARP VIP as Interface

Added by Christian McDonald 3 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
01/29/2021
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
Release Notes:
Default

Description

If a GIF instance has its interface set to an IP Alias VIP which uses a CARP VIP as its own interface, the Interface column in the GIF tunnel list is empty.

The problem does not affect GIF tunnels on CARP VIPs directly, and GRE interfaces are likewise unaffected.

gif issue.PNG (23.9 KB) gif issue.PNG Christian McDonald, 01/29/2021 12:36 PM
gif issue 2.PNG (85.1 KB) gif issue 2.PNG Christian McDonald, 01/29/2021 12:38 PM

History

#2 Updated by Viktor Gurov 3 months ago

  • Status changed from New to Rejected

Unable to reproduce it on the latest 2.5 snapshot,
Interface column is OK if I select CARP VIP as a parent interface

This site is not for support or diagnostic discussion.

For assistance in solving problems, please post on the Netgate Forum or the pfSense Subreddit .

See Reporting Issues with pfSense Software for more information.

#3 Updated by Christian McDonald 3 months ago

Ok... The tunnel works fine, this is just a cosmetic issue, not looking for support. It's trivially reproducible on my end, but if you feel that my screenshots represent expected behavior, then yes please close this report

#4 Updated by Christian McDonald 2 months ago

instead of having multiple CARP VIPs attached to WAN, I have one CARP VIP and the IP Aliases that follow that CARP VIP...as per the recommendation of Jim from years ago when we still had Hangouts. When I assign one of these IP Aliases as the parent interface for the GIF tunnel, it is not shown in the table.

My title was not clear...my apologies.

#5 Updated by Jim Pingle 2 months ago

  • Subject changed from Interface column empty in list of GIF tunnels when using CARP VIP as Interface to Interface column empty in list of GIF tunnels when using IP Alias on CARP VIP as Interface
  • Description updated (diff)
  • Status changed from Rejected to New
  • Target version deleted (2.5.0)

The description was inaccurate. As stated, there was no problem. The problem exists only when the interface is set to an IP Alias VIP which uses a CARP VIP as its interface, which is different. I've updated the subject and description to reflect the real problem.

Also available in: Atom PDF