Project

General

Profile

Actions

Regression #11512

closed

DHCP Leases page and ARP table page fail to load if DNS is not available

Added by Brad Lavis about 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
02/23/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:

Description

From jimp: "Once upon a time it used to test for DNS on those pages and skip it if DNS didn't respond. Maybe that got broken."

Discussion thread -
https://forum.netgate.com/topic/161121/after-upgrade-to-2-5-status_dhcp_leases-php-nor-diag_arp-php-will-load


Related issues

Related to Regression #13162: GUI Update not working when using only ipv6 DNS serversFeedbackViktor Gurov

Actions
Is duplicate of Bug #12709: RRD stats have many dropouts in all databases, with DHCPD RRD logging enabled and broken reverse DNSDuplicate

Actions
Actions #1

Updated by Jim Pingle about 1 year ago

  • Tracker changed from Bug to Regression
  • Target version set to CE-Next
Actions #2

Updated by Karl Fife about 1 year ago

Actions #4

Updated by Anonymous 8 months ago

  • Assignee set to Viktor Gurov

We don't yet know if this issue affects Plus. No reports originating from that version have been observed.

Actions #5

Updated by Jim Pingle 8 months ago

  • Status changed from New to Pull Request Review
  • Plus Target Version set to 22.01
Actions #6

Updated by Viktor Gurov 8 months ago

the MR/patch works as expected - https://forum.netgate.com/topic/161424/dhcp-lease-screen-not-loading/86:

@viktor_g The patch resolved the issue for me.
Status / DHCP Leases page now loads immediately. (had been taking ~40 seconds since the 2.5.2 upgrade).
Thanks.

Actions #7

Updated by Viktor Gurov 7 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #8

Updated by Ronald Schellberg 7 months ago

Noticed when executing a ndp diagnostic query, that _getHostName() is now declared in both diag_ndp.php and system.inc.

I assume the declaration at line 103 in diag_ndp.php should be removed.

Actions #9

Updated by Viktor Gurov 7 months ago

Ronald Schellberg wrote in #note-8:

Noticed when executing a ndp diagnostic query, that _getHostName() is now declared in both diag_ndp.php and system.inc.

I assume the declaration at line 103 in diag_ndp.php should be removed.

fix:
https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/417

Actions #10

Updated by Jim Pingle 7 months ago

  • Status changed from Feedback to Pull Request Review
  • Target version changed from CE-Next to 2.6.0
Actions #11

Updated by Viktor Gurov 7 months ago

  • Status changed from Pull Request Review to Feedback
Actions #12

Updated by Jim Pingle 7 months ago

  • Subject changed from status_dhcp_leases.php and diag_arp.php fail to load if DNS doesn't respond to DHCP Leases page and ARP table page fail to load if DNS is not available

Updating subject for release notes.

Actions #13

Updated by Viktor Gurov 4 months ago

  • Is duplicate of Bug #12709: RRD stats have many dropouts in all databases, with DHCPD RRD logging enabled and broken reverse DNS added
Actions #14

Updated by Viktor Gurov 4 months ago

  • Status changed from Feedback to Duplicate

system_get_dhcpleases() fixed in #11512

Actions #15

Updated by Jim Pingle 4 months ago

  • Status changed from Duplicate to Feedback
Actions #16

Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Closed
Actions #17

Updated by Viktor Gurov 4 days ago

  • Related to Regression #13162: GUI Update not working when using only ipv6 DNS servers added
Actions

Also available in: Atom PDF