Project

General

Profile

Actions

Bug #11600

closed

WireGuard interfaces should have MSS clamping enabled by default

Added by Christian McDonald 5 months ago. Updated 3 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
Category:
WireGuard
Target version:
-
Start date:
03/02/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:

Description

It would seem that there is an upstream bug with wireguard icmp and path discovery (?) : https://git.kernel.org/pub/scm/linux/kernel/git/netdev/net.git/commit/?id=ee576c47db60

All my issues were resolved by setting the MSS field to 1420 (which enables an mss clamp of 1380) on my assigned wireguard interfaces.

Actions #2

Updated by Jim Pingle 5 months ago

  • Status changed from New to Pull Request Review
  • Target version set to CE-Next
Actions #3

Updated by Jim Pingle 5 months ago

  • Target version changed from CE-Next to 2.5.1
Actions #4

Updated by Renato Botelho 5 months ago

  • Status changed from Pull Request Review to Waiting on Merge
  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

Actions #5

Updated by Renato Botelho 5 months ago

  • Status changed from Waiting on Merge to Feedback
Actions #6

Updated by Renato Botelho 5 months ago

Cherry-picked to RELENG_2_5_1

Actions #7

Updated by Jim Pingle 5 months ago

  • Subject changed from WireGuard interfaces should be mss clamped by default to WireGuard interfaces should have MSS clamping enabled by default

Updating subject for release notes.

Actions #8

Updated by Jim Pingle 4 months ago

  • Target version changed from 2.5.1 to Future
Actions #9

Updated by Christian McDonald 3 months ago

This seems to no longer be a requirement, as WireGuard by design should be able to pass larger MTUs within the tunnel.

Not seeing this on the latest kmod code

Actions #10

Updated by Renato Botelho 3 months ago

  • Status changed from Feedback to Not a Bug
Actions #11

Updated by Jim Pingle 3 months ago

  • Target version deleted (Future)
Actions

Also available in: Atom PDF