Project

General

Profile

Regression #11747

Firewall rule schedule cannot be changed

Added by Viktor Gurov about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Rules / NAT
Target version:
Start date:
03/28/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:

Description

Running on latest Version 2.5.0
When I modify the schedule, it will not save any longer

I get the following error:

The following input errors were detected:

Invalid start time - ''

When I added an additional time it worked
When I deleted a time from a few days ago and try to save it, it shows above error

https://forum.netgate.com/topic/161476/schedule-can-not-saved
When I deleted a time from a few days ago and try to save it, it shows above error

Associated revisions

Revision 18f7c1cb (diff)
Added by Viktor Gurov about 2 months ago

Firewall Schedules edit fix. Issue #11747

Revision 3bf54e0d (diff)
Added by Viktor Gurov about 2 months ago

Firewall Schedules edit fix. Issue #11747

(cherry picked from commit 18f7c1cb378cbfc8109c4aff3eb734048a4bc299)

History

#1 Updated by Viktor Gurov about 2 months ago

it also fixes error:

[28-Mar-2021 15:16:30 Europe/Moscow] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /usr/local/www/firewall_schedule_edit.php on line 461
[28-Mar-2021 15:16:30 Europe/Moscow] PHP Warning:  Invalid argument supplied for foreach() in /usr/local/www/firewall_schedule_edit.php on line 463

when deleting the last timerange + saving

https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/210

#2 Updated by Jim Pingle about 2 months ago

  • Tracker changed from Bug to Regression
  • Subject changed from Schedule cannot be changed to Firewall rule schedule cannot be changed
  • Target version set to 2.5.1

#3 Updated by Jim Pingle about 2 months ago

  • Status changed from New to Pull Request Review

#4 Updated by Jim Pingle about 2 months ago

  • Status changed from Pull Request Review to Feedback

PR merged to master, after it's tested there we can consider cherry picking to 21.02.2/2.5.1 since it's a significant regression.

#5 Updated by Jim Pingle about 2 months ago

  • % Done changed from 0 to 100

Patch works for me when I test it, picked back so it doesn't get missed.

#6 Updated by Renato Botelho about 2 months ago

  • Assignee set to Jim Pingle

#7 Updated by Alhusein Zawi about 1 month ago

I was able to modify Schedules when it is applied to FW rule (added/deleted)

2.5.1-RC (amd64)
built on Tue Apr 06 13:08:56 EDT 2021
FreeBSD 12.2-STABLE

#8 Updated by Jim Pingle about 1 month ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF