Project

General

Profile

Feature #11750

qlnxe kernel module missing in 2.5.0

Added by Franky Van Liedekerke about 2 months ago. Updated 19 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Hardware / Drivers
Target version:
-
Start date:
03/29/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default

Description

In 2.5.0 if_qlnxe is missing as a module (or compiled in). In 2.4.5 this was also the case but there I was able to copy over the relevant module from a stock freebsd release and use that. However trying to use if_qlnxe.ko from freebsd 12.2 fails in pfsense 2.5.0 (it seems the kernel and module don't match). So I was wondering:
- can this module be provided as a ko-file so we can proceed our upgrade to 2.5.0 ?
- can this module be compiled-in for future releases?

Regards,
Franky

History

#1 Updated by Viktor Gurov about 1 month ago

  • Tracker changed from Bug to Feature
  • Affected Architecture deleted (amd64)

#2 Updated by Layla Mah 19 days ago

Viktor Gurov wrote:

https://gitlab.netgate.com/pfSense/FreeBSD-src/-/merge_requests/11

That GitLab link seems broken.

I'd like to second this request. I just tried adding:

if_qlnxe_load="YES" 

to loader.conf, and was dismayed to find that qlnxe seems to be removed from pfSense even though it's available in FreeBSD 12.2. This is a 100% blocking issue for us using pfSense going forward.

Also available in: Atom PDF