Project

General

Profile

Actions

Regression #11787

closed

Thermal sensors widget no longer shows values from certain hardware

Added by Steve Wheeler 7 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Dashboard
Target version:
Start date:
04/06/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.05
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:
amd64

Description

The changes made for this bug: https://redmine.pfsense.org/issues/10963 excluded the Chelsio sysctl temperature values from the widget.

It needs to show values for dev.t5nex additionally.

Tested: 21.02.1

Actions #2

Updated by Jim Pingle 7 months ago

  • Subject changed from Thermal sensors widget no longer shows Chelsio NIC values to Thermal sensors widget no longer shows values from certain hardware
  • Status changed from New to Pull Request Review

Looks like a couple others are also missing from the output, not just Chelsio. See my notes on the PR.

Actions #3

Updated by Jim Pingle 6 months ago

  • Plus Target Version set to 21.05
Actions #4

Updated by Steve Beaver 6 months ago

  • Status changed from Pull Request Review to Feedback
Actions #5

Updated by Jim Pingle 6 months ago

This should also fix the thermal sensors widget on the 3100 (#11673)

Actions #6

Updated by Jim Pingle 5 months ago

  • Status changed from Feedback to Closed
  • Assignee set to Steve Wheeler

This is good now. The other devices are being included. I don't have a Chelsio card to check but given that the others work I don't see any reason why it would fail. If it does, can reopen.

Actions #7

Updated by Jim Pingle 5 months ago

  • Target version changed from CE-Next to 2.5.2
Actions #8

Updated by Michael Smith 3 months ago

Hello, I just tried this on a Chelsio T6 card. I can get the temp ("dev.t6nex.0.temperature") for the card at the command line but it's not in the 2.5.2-RELEASE gui. Thanks!

sysctl -a | grep temperature

hw.acpi.thermal.tz0.temperature: 27.9C
dev.t6nex.0.temperature: 57
dev.cpu.5.temperature: 34.0C
dev.cpu.4.temperature: 35.0C
dev.cpu.3.temperature: 34.0C
dev.cpu.2.temperature: 34.0C
dev.cpu.1.temperature: 35.0C
dev.cpu.0.temperature: 36.0C

Actions

Also available in: Atom PDF