Project

General

Profile

Actions

Bug #11840

closed

Dynamic DNS edit page incorrectly hides username field when switching away from Digital Ocean

Added by Jaakko Kantojärvi 3 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Dynamic DNS
Target version:
Start date:
04/22/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
21.05
Release Notes:
Default
Affected Version:
Affected Architecture:
All

Description

Dynamic DNS page hides `username` field from all providers if `digitalocean` or `gandi-livends` is selected. The field is restored if `domeneshop` is selected.

I'm working on a fix.

Actions #2

Updated by Jim Pingle 3 months ago

  • Status changed from New to Pull Request Review
  • Target version set to CE-Next
Actions #3

Updated by Jim Pingle 2 months ago

  • Plus Target Version set to 21.05
Actions #4

Updated by Steve Beaver 2 months ago

  • Status changed from Pull Request Review to Feedback
Actions #5

Updated by Jaakko Kantojärvi 2 months ago

  • % Done changed from 0 to 100
Actions #6

Updated by Jim Pingle 2 months ago

  • Subject changed from Dynamic DNS (dyndns) edit page hides username field when digitalocean is selected to Dynamic DNS edit page hides username field for Digital Ocean

Updating subject for release notes.

Actions #7

Updated by Kris Phillips 2 months ago

Tested this on the May 15th 21.05 RC build and the issue is still able to replicated. Username field still disappears for me in Firefox.

Actions #8

Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to New
Actions #9

Updated by Jaakko Kantojärvi 2 months ago

Please notice that the logic, as I understood it from the code, was to hide the field for DigitalOcean. However, the field was not restored when another provider was selected (except domeneshop worked correctly).

It's of course possible, that username is required with DigitalOcean. I have not used that provider, so I can't be sure.

On that note, I think the title of the issue was and is still wrongly worded. My bad on the initial title.

Actions #10

Updated by Jim Pingle 2 months ago

  • Subject changed from Dynamic DNS edit page hides username field for Digital Ocean to Dynamic DNS edit page incorrectly hides username field when switching away from Digital Ocean
  • Status changed from New to Resolved
  • Target version changed from CE-Next to 2.6.0

OK so that's my fault on the title change -- I misread it as well.

I tested it the intended way and now after switching away from DO I get the username field back.

Hopefully I've got the subject corrected better this time.

Actions #11

Updated by Jim Pingle about 2 months ago

  • Target version changed from 2.6.0 to 2.5.2
Actions #12

Updated by Renato Botelho about 1 month ago

  • Assignee set to Steve Beaver
Actions

Also available in: Atom PDF