Project

General

Profile

Actions

Bug #11894

open

Vouchers may expire too early when using RAM disks

Added by Volker Werbus 5 months ago. Updated about 1 month ago.

Status:
Feedback
Priority:
Normal
Assignee:
Category:
Captive Portal
Target version:
Start date:
05/05/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default
Affected Version:
2.5.1
Affected Architecture:
amd64

Description

We just upgraded around 10 sites from 2.4.5 to 2.5.1 and detected a strange behavior: We have created 3 voucher rolls with 2.4.5 and upgraded to 2.5.1 All of the sudden around 280 vouchers expired instantly. We deleted all voucher rolls and created (identical) new ones with 2.5.1 - and thought this solves the problem. For a few day all was fine. Today one site had a power outage and the system rebooted - and again around 280 vouchers expired. The sites without reboot are still running fine - however, the same problem occured after upgrade.
Some information about the hardware: We used APU1D4 and APU2E0 appliances.
And it is not just us having this problem, see this thread: https://forum.netgate.com/topic/162708/vouchers-getting-expired-before-remaining-time

Actions #1

Updated by Viktor Gurov 5 months ago

from https://forum.netgate.com/topic/162708/vouchers-getting-expired-before-remaining-time/15:
"Voucher system working perfectly on this snapshot

2.5.0.a.20210107.2142 ( Development )

up to 2500 captive portal users renew monthly basis and there is not a single issue reported about voucher's early expiry."

but there are no special changes in captiveportal.inc/voucher.inc from that version to 2.5.1,
only #11360 and #11475

Actions #3

Updated by Volker Werbus 5 months ago

I don't think so. We are not using HA sync on the appliance.

Actions #5

Updated by Jim Pingle 5 months ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.6.0
Actions #6

Updated by Renato Botelho 2 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov
  • Plus Target Version set to 21.09

PR has been merged. Thanks!

Actions #7

Updated by Jim Pingle about 1 month ago

  • Subject changed from Vouchers expire too early to Vouchers may expire too early when using RAM disks

Updating subject for release notes.

Actions

Also available in: Atom PDF