Project

General

Profile

Actions

Bug #11946

closed

Custom value for AutoConfigBackup schedule Hours is not shown when loading the settings page

Added by Jim Pingle 5 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Backup / Restore
Target version:
Start date:
05/21/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

When ACB is set to use a schedule on services_acb_settings.php, a the hour value from config.xml is not populated on the page. It always loads at 0. The correct value is placed into config.xml and is used as expected, but it is not shown to the user on the page.

If the user is not careful, the next time they visit the page to make a change, their chosen hour will reset to 0 unless they re-add their custom value.

Actions #1

Updated by Michael Spears 5 months ago

Jim Pingle wrote:

When ACB is set to use a schedule on services_acb_settings.php, a the hour value from config.xml is not populated on the page. It always loads at 0. The correct value is placed into config.xml and is used as expected, but it is not shown to the user on the page.

If the user is not careful, the next time they visit the page to make a change, their chosen hour will reset to 0 unless they re-add their custom value.

I reproduced this.

Actions #3

Updated by Jim Pingle 5 months ago

  • Status changed from New to Pull Request Review
Actions #4

Updated by Renato Botelho 5 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

Actions #5

Updated by Max Leighton 4 months ago

Tested in 2.6.0. The specified hour will now stay on the page when after navigating away and navigating back.

However, I'm still seeing this in

21.09-DEVELOPMENT (arm64)
built on Sat Jun 05 01:09:01 EDT 2021
FreeBSD 12.2-STABLE

Actions #6

Updated by Renato Botelho 4 months ago

Cherry-picked to 2.5.2-RC

Actions #7

Updated by Jim Pingle 4 months ago

  • Status changed from Feedback to Closed

Works with the latest RELENG_2_5_2 code in place.

Actions #8

Updated by Jim Pingle about 2 months ago

  • Subject changed from AutoConfigBackup schedule custom hour value lost on page load to Custom value for AutoConfigBackup schedule Hours is not shown when loading the settings page

Updating subject for release notes.

Actions

Also available in: Atom PDF