Project

General

Profile

Actions

Bug #12038

closed

System attempts to start inactive services at boot

Added by Viktor Gurov 4 months ago. Updated 8 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Services
Target version:
Start date:
06/15/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default
Affected Version:
2.5.1
Affected Architecture:

Description

Updating configuration...done
Starting Secure Shell Services...done
Syncing OpenVPN settings...done.
Setting up gateway monitors...done
Setting up DNSs...done
Setting up static routes...done

- there is no need to show such messages when the corresponding services are not enabled

see also #12002

Actions #2

Updated by Jim Pingle 4 months ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.6.0
  • Plus Target Version set to 21.09
Actions #3

Updated by Renato Botelho 4 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

Actions #4

Updated by Jim Pingle about 2 months ago

  • Subject changed from `Syncing/Starting XXX...` message on boot when corresponding service is not configured to System attempts to start inactive services at boot

Updating subject for release notes.

Actions #5

Updated by Alhusein Zawi about 2 months ago

disabled services will be enabled after rebooting

I disabled DNS Resolver and IPsec VPN services from Status>Services, they have been started after rebooting

2.6.0.a.20210827.0100

Actions #6

Updated by Jim Pingle about 2 months ago

That does not and is not supposed to disable them. It stops them temporarily. That's working as intended.

Actions #7

Updated by Kris Phillips 9 days ago

Tested on 22.01. Looks good and disabled services don't show in the startup as far as I can tell.

Actions #8

Updated by Viktor Gurov 8 days ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF