Project

General

Profile

Actions

Bug #12049

closed

Input validation incorrectly rejects a second IPv4-only GRE tunnel

Added by Peter Van Overveldt 4 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Interfaces
Target version:
Start date:
06/17/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default
Affected Version:
2.5.2
Affected Architecture:

Description

More info:

-> This only occurs when creating A 2ND SUCH TUNNEL FOR THE SAME "Parent Interface" 
-> The "GRE-tunnel-Creation-page I am referring to, is under Menu "Interfaces" -> "Assignements" -> GREs-tab -> "+ Add"
-> This was not the case in earlier versions of pfsense; we were able to define GRE-tunnels this way in the past just fine.
-> I got this error with version 2.5.1. 2.5.2 is indicated below, because 2.5.1 isn't selectable.
Actions #1

Updated by Renato Botelho 4 months ago

  • Target version changed from 2.5.2 to CE-Next

This is not a regression. Too late for 2.5.2

Actions #3

Updated by Jim Pingle 4 months ago

  • Status changed from New to Pull Request Review
  • Target version changed from CE-Next to 2.6.0
  • Plus Target Version set to 21.09
Actions #4

Updated by Renato Botelho 4 months ago

  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

Actions #5

Updated by Renato Botelho 4 months ago

  • Status changed from Pull Request Review to Feedback
Actions #6

Updated by Max Leighton 3 months ago

Tested in

21.09-DEVELOPMENT (amd64)
built on Sat Jul 17 01:10:40 EDT 2021
FreeBSD 12.2-STABLE

It works. I was able to successfully create two GRE tunnels with blank IPv6 addresses.

Actions #7

Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Resolved
  • Affected Version changed from 2.5.1 to 2.5.2
Actions #8

Updated by Jim Pingle 2 months ago

  • Subject changed from GRE tunnels: attempt to create of an IPv4-only GRE-tunnel ( by leaving empty "Local IPv6 tunnel address." and "Remote IPv6 address address.") results in "A GRE tunnel with the same IPv6 tunnel network is already defined.". to Input validation incorrectly rejects a second IPv4-only GRE tunnel
  • Category changed from Web Interface to Interfaces

Updating subject for release notes.

Actions

Also available in: Atom PDF