Project

General

Profile

Actions

Bug #12107

closed

Notifications page cannot be saved without configuring or disabling SMTP

Added by Steve Wheeler 4 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
07/05/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
21.09
Release Notes:
Default
Affected Version:
Affected Architecture:
All

Description

In System > Advanced > Notifications page you can only save changes to any value on the page if the email section is either correctly configured for sending email or the 'Disable SMTP Notifications' box is checked.
In the default case, where neither of those things are true, any other changes on the page appear to save but are not actually put in the config.

No error is shown.

No errors are logged.

Actions #1

Updated by Jim Pingle 4 months ago

  • Status changed from New to Feedback

Someone else reported this in #11955 but I couldn't reproduce it at the time, and I still can't reproduce it on 2.5.2. I tried on two different systems which had never touched the notification settings and it worked on both.

There must be something else happening here, either a browser plugin auto-filling incomplete settings or some partial config in config.xml which is now rejected.

Either way, we need to know the exact conditions which bring out the problem to know if there is anything we can do.

Actions #2

Updated by Steve Wheeler 4 months ago

  • Status changed from Feedback to New

Steps to replicate:
Install pfSense clean. I used a 2.5.2 image here but have also see it in 21.05 and 2.5.1.
Skip the setup wizard and go to System > Advanced > Notifications. I have also see this after running the wizard though and on older installs.
Check 'Disable the startup/shutdown beep' and save the page.
It will appear to save but returns very quickly. No error is shown.
If you refresh the page 'Disable the startup/shutdown beep' will not be set and nothing will be written to the config.

Actions #3

Updated by Max Leighton 3 months ago

I can confirm that this is reproducible with those steps.

Actions #4

Updated by Viktor Gurov 3 months ago

It will appear to save but returns very quickly. No error is shown.
If you refresh the page 'Disable the startup/shutdown beep' will not be set and nothing will be written to the config.

- caused by missing `$input_errors`

fix:
https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/300

Actions #5

Updated by Jim Pingle 3 months ago

  • Status changed from New to Pull Request Review
  • Target version changed from CE-Next to 2.6.0
  • Plus Target Version changed from Plus-Next to 21.09
Actions #6

Updated by Renato Botelho 3 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

Actions #7

Updated by Renato Botelho 3 months ago

  • % Done changed from 0 to 100
Actions #8

Updated by Danilo Zrenjanin 3 months ago

  • Status changed from Feedback to Resolved

Tested on the:

2.6.0-DEVELOPMENT (amd64)
built on Thu Jul 22 01:08:06 EDT 2021
FreeBSD 12.2-STABLE

It works fine.

Actions

Also available in: Atom PDF