Project

General

Profile

Actions

Feature #12116

closed

Support DNS server gateway selection on ``system.php`` for multiple gateways not assigned to interfaces

Added by Stammes Opfer 10 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Gateways
Target version:
Start date:
07/08/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Default

Description

When pfSense only has a single interface with upstream gateway configured but multiple manually added gateways. The gateway selection drop down in General Settings > DNS is not shown.

Actions #1

Updated by Jim Pingle 10 months ago

  • Tracker changed from Bug to Feature
  • Project changed from pfSense Plus to pfSense
  • Subject changed from DNS Server Gateway Selection missing to Support DNS server gateway selection on ``system.php`` for multiple gateways not assigned to interfaces
  • Category changed from Web Interface to Gateways
  • Priority changed from Normal to Low

Currently that is the correct and expected behavior. To activate Multi-WAN support, multiple interfaces must have a gateway set on the interface itself. If they are dynamically addressed, this happens automatically. If they are static, you have to pick the gateway on the assigned interface.

That said, that may not be the best way to determine whether or not that field should appear on system.php for DNS servers. While not a bug, we can look into adding support for that scenario in the future.

In the meantime you can always use manual static routes.

Actions #3

Updated by Jim Pingle 6 months ago

  • Status changed from New to Pull Request Review
  • Assignee set to Viktor Gurov
  • Target version set to 2.6.0
  • Plus Target Version set to 22.01
Actions #4

Updated by Viktor Gurov 6 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #5

Updated by Danilo Zrenjanin 6 months ago

  • Status changed from Feedback to Resolved

Tested against:

2.6.0-DEVELOPMENT (amd64)
built on Thu Nov 25 06:22:35 UTC 2021
FreeBSD 12.3-PRERELEASE

It works as expected. Ticket resolved.

Actions

Also available in: Atom PDF