Project

General

Profile

Actions

Bug #12192

closed

OpenVPN does not clean up previous CA and CRL files

Added by Rafael Grothmann 6 months ago. Updated 3 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Create a Peer to Peer (SSL/TLS) with Peer Certificate Authority One. After saving change the Peer Certificate Authority to another called Two and save again. Now we changing it back to one and save. Now i can login with the certificat from two. Restarting the vpn server bring no result. Only rebooting worked.

Actions #1

Updated by Jim Pingle 6 months ago

  • Subject changed from OpenVPN Allow acces with wrong certificates to OpenVPN does not clean up previous CA files
  • Status changed from New to Confirmed
  • Assignee set to Jim Pingle
  • Target version set to 2.6.0
  • Plus Target Version set to 21.09
Actions #2

Updated by Jim Pingle 6 months ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100
Actions #3

Updated by Jim Pingle 5 months ago

  • Subject changed from OpenVPN does not clean up previous CA files to OpenVPN does not clean up previous CA and CRL files

Updating subject for release notes.

Actions #4

Updated by Jim Pingle 3 months ago

  • Plus Target Version changed from 21.09 to 22.01
Actions #5

Updated by Jim Pingle 3 days ago

  • Status changed from Feedback to Resolved

This has been working well since it went in.

Actions

Also available in: Atom PDF