Project

General

Profile

Actions

Regression #12631

closed

Dynamic DNS may not use the correct interface when updating during failover

Added by Neill Lawson-Smith 5 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Dynamic DNS
Target version:
Start date:
12/22/2021
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Default
Affected Version:
2.5.2
Affected Architecture:

Description

Using 2.5.2-RELEASE

I have two interfaces - One WAN (gigabit) and a 4G Data Cell Link (150Mbps) as a secondary.
The WAN is Tier 1 and 4G is Tier 2 in a Gateway Group for failover.

If WAN 1 is unplugged, the 4G failover works no problem, however DynamicDNS fails to work - reporting that there is no response from NoIP (dyndns URL) - and the DNS record is not updated.
The same Dynamic update works if the WAN connection is reconnected. The default routing path is set to the Routing Group (and also tested with Automatic - but no effect).

If however the CUSTOM Dynamic DNS option is selected, you get an extra box for "Which Interface to send update from" - which I select the Routing Group - after adding the manual update URL string for NoIP, the updating on failover works perfectly.

It appears that all the standard Dynamic DNS providers are not updating/obeying the routing setup (so possibly using the standard WAN as the only interface).

Any suggestions welcome - happy to put up a config or activity log as this is in a non-production environment.


Related issues

Related to Bug #9641: Dynamic DNS cannot update AAAA records on 6rd tunnel interfaces bound to PPPoE interfacesResolvedRenato Botelho07/21/2019

Actions
Is duplicate of Bug #11958: Multi-wan Azure Dyndns updates not working when primary WAN is unpluggedDuplicate05/24/2021

Actions
Actions #1

Updated by Neill Lawson-Smith 5 months ago

So an update....

I found that the Dynamic DNS option for "Custom" displays a drop down for "Interface to send update from" that is not available on any of the other Dynamic DNS providers. I noted that this defaults to the "Wan" interface rather than the Gateway Group as expected.

A workaround for this is to backup your config as an XML file, edit the XML file with a text editor, and look for the <dyndns> section (mine was towards the bottom) - under the XML config data for the Dynamic DNS provider that you have setup (do set it up beforehand), there is a tag <requestif>Wan</requestif> which records the Interface to send the request updates from - I changed mine to <requestif>AutoFailoverGateway</requestif> (my Gateway Group is called "AutoFailoverGateway"), then restore the config file - and hey presto, it works as expected.

So the bug is that the "Interface to send update from" field needs to be available for all Dynamic DNS Providers so that this can be set within the Admin interface.

Hope that helps everyone who comes across this

Actions #2

Updated by Viktor Gurov 5 months ago

  • Tracker changed from Bug to Regression
  • Affected Version set to 2.5.2
Actions #4

Updated by Viktor Gurov 5 months ago

  • Related to Bug #9641: Dynamic DNS cannot update AAAA records on 6rd tunnel interfaces bound to PPPoE interfaces added
Actions #6

Updated by Viktor Gurov 5 months ago

  • Assignee set to Viktor Gurov
Actions #7

Updated by Jim Pingle 5 months ago

  • Status changed from New to Pull Request Review
  • Target version set to CE-Next
  • Plus Target Version set to 22.05
Actions #8

Updated by Jim Pingle 5 months ago

  • Target version changed from CE-Next to 2.6.0
  • Plus Target Version changed from 22.05 to 22.01
Actions #9

Updated by Viktor Gurov 5 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #10

Updated by Jim Pingle 5 months ago

  • Subject changed from Default Route Not Used Properly for Dynamic DNS in Failover to Dynamic DNS may not use the correct interface for making updates during failover

Updating subject for release notes.

Actions #11

Updated by Jim Pingle 5 months ago

  • Subject changed from Dynamic DNS may not use the correct interface for making updates during failover to Dynamic DNS may not use the correct interface when updating during failover
Actions #12

Updated by Viktor Gurov 4 months ago

  • Is duplicate of Bug #11958: Multi-wan Azure Dyndns updates not working when primary WAN is unplugged added
Actions #13

Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF