Project

General

Profile

Bug #1288

Single Wan multi Lan Traffic Shaper Wizard :: "You do not have 2 of local interfaces!"

Added by brandon b over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Traffic Shaper
Target version:
Start date:
02/16/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

My test box has 3 total interfaces, all of which are properly connected to physical interfaces and function on their own.
They are: WAN, LAN and OPT1

The problem is that the Single Wan multi Lan wizard states "You do not have 2 of local interfaces!" when I tell it I have two LANs to configure.

Similarly the Multiple Lan/Wan wizard does not even show OPT1 as a choice in the dropdown menu for interfaces, thus making it impossible to set up a multi LAN configuration.

Re-creatable in the latest nightly as of 2/16/11

Associated revisions

Revision c2d7074e (diff)
Added by Ermal Luçi about 8 years ago

Resolves #1288. Add alc(4) to altq(4) supported list.

History

#1 Updated by brandon b over 8 years ago

Update to reference this forum thread where a similar (though single lan) issue appears to be affecting another test user.

http://forum.pfsense.org/index.php?topic=33026.0

#2 Updated by Ermal Luçi over 8 years ago

Possibly your nic type does not support altq.

Can you do an ifconfig and paste the output here?

#3 Updated by brandon b over 8 years ago

[2.0-BEAT5][]/root(34): ifconfig
em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC>
ether 00:1b:21:76:0a:13
inet6 fe80::21b:21ff:fe76:a13%em0 prefixlen 64 scopeid 0x1
inet 192.168.50.89 netmask 0xffffff00 broadcast 192.168.50.255
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
alc0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=c3198<VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC,VLAN_HWTSO,LINKSTATE>
ether 1c:6f:65:64:75:a4
media: Ethernet autoselect
em1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=209b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC>
ether 00:1b:21:7c:9f:36
inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
inet6 fe80::21b:21ff:fe7c:9f36%em1 prefixlen 64 scopeid 0x3
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
media: Ethernet autoselect (1000baseT <full-duplex>)
status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
options=3<RXCSUM,TXCSUM>
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
pflog0: flags=100<PROMISC> metric 0 mtu 33200
pfsync0: flags=0<> metric 0 mtu 1460
syncpeer: 224.0.0.240 maxupd: 128
enc0: flags=0<> metric 0 mtu 1536

#4 Updated by brandon b over 8 years ago

Interesting/surprising update:

I reconfigured this box and tested it as a dual WAN single LAN setup and found that the multi wan/lan wizard fails in a similar way. It won't allow me to select the second WAN connection..it just flat doesn't show up in the dropdown list. This also makes it impossible to complete the setup since you can't go forward with only one WAN selected if you've told it you have two.

#5 Updated by Ermal Luçi about 8 years ago

  • Status changed from New to Resolved

Should be fixed on new snapshot.
The alc(4) driver was not on altq(4) supported interface list.

Also available in: Atom PDF