Project

General

Profile

Bug #1325

some package won't start after install

Added by chudy fernandez over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
Start date:
03/05/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Confusing though. Starting service but doesn't do anything within the code.
/etc/inc/pkg-utils.inc

} else {
$static_output .= "Writing configuration... ";
update_output_window($static_output);
write_config($changedesc);
$static_output .= "done.\n";
update_output_window($static_output);
$static_output .= "Starting service.\n";
update_output_window($static_output);
if($pkg_info['after_install_info'])
update_output_window($pkg_info['after_install_info']);
}

that line should be remove? if follow what is says "Starting service" then patch below.
This should start package after install

--- /etc/inc/pkg-utils.inc.old 2011-03-05 19:23:38.000000000 +0000
+++ /etc/inc/pkg-utils.inc 2011-03-05 20:22:29.000000000 +0000
@ -593,6 +593,7 @
$static_output .= "done.\n";
update_output_window($static_output);
$static_output .= "Starting service.\n";
+ start_service($pkg_info['name']);
update_output_window($static_output);
if($pkg_info['after_install_info'])
update_output_window($pkg_info['after_install_info']);

Associated revisions

Revision 8171fcd9 (diff)
Added by Scott Ullrich over 12 years ago

Reset dynamic dns upon pppoe forced disconnect.

Ticket #1325

History

#1 Updated by Ermal Lu├ži over 8 years ago

  • Status changed from New to Closed

A service will not be started anymore after install.
It is changed behaviour from 1.2.x

Also available in: Atom PDF