Project

General

Profile

Actions

Bug #13348

open

Boot Environments GUI displays error

Added by Marcos M 3 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Category:
Web Interface
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Default
Affected Plus Version:
22.05
Affected Architecture:

Description

After attempting to delete a "quick" boot environment, the GUI displayed the following error:

The following input errors were detected:
* Unable to delete boot environment "quick-20220707003613". Error 21

However, neither the GUI nor running zfs list -t snapshot list the entry, hence it was indeed deleted.

Actions #1

Updated by Marcos M 3 months ago

  • Description updated (diff)
Actions #2

Updated by Jim Pingle 3 months ago

  • Assignee set to Christian McDonald
  • Target version set to 22.11

I can't reproduce this here so far. I can create a quick BE and then delete it without error. Though I haven't tried to delete an older quick BE or delete one after activating it and using it.

There may be more involved in reproducing it than just having it be a quick BE.

That said, if it was removed, perhaps the error checking could test for that and make the text state it was still removed (e.g. a warning instead of a fatal error)

Actions #3

Updated by Marcos M 2 months ago

I don't recall the details when discussing it with Christian, but he mentioned something along the lines of the issue potentially being due it trying to delete something in the snapshot chain that no longer existed.

Actions #4

Updated by Kris Phillips 2 months ago

I cannot reproduce this either. Hopefully Christian can provide some insight into what might be the reproducible steps for this bug, because I can create and destroy quick snapshots all day.

Actions

Also available in: Atom PDF