Project

General

Profile

Actions

Bug #13348

closed

Error when deleting ZFS Boot Environment created from duplicate of non-default entry

Added by Marcos M about 2 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Default
Affected Plus Version:
22.05
Affected Architecture:

Description

After attempting to delete a "quick" boot environment, the GUI displayed the following error:

The following input errors were detected:
* Unable to delete boot environment "quick-20220707003613". Error 21

However, neither the GUI nor running zfs list -t snapshot list the entry, hence it was indeed deleted.


Related issues

Has duplicate Bug #14224: Error when deleting Boot Environment that was the source for a cloneDuplicate

Actions
Actions #1

Updated by Marcos M about 2 years ago

  • Description updated (diff)
Actions #2

Updated by Jim Pingle about 2 years ago

  • Assignee set to Christian McDonald
  • Target version set to 23.01

I can't reproduce this here so far. I can create a quick BE and then delete it without error. Though I haven't tried to delete an older quick BE or delete one after activating it and using it.

There may be more involved in reproducing it than just having it be a quick BE.

That said, if it was removed, perhaps the error checking could test for that and make the text state it was still removed (e.g. a warning instead of a fatal error)

Actions #3

Updated by Marcos M almost 2 years ago

I don't recall the details when discussing it with Christian, but he mentioned something along the lines of the issue potentially being due it trying to delete something in the snapshot chain that no longer existed.

Actions #4

Updated by Kris Phillips almost 2 years ago

I cannot reproduce this either. Hopefully Christian can provide some insight into what might be the reproducible steps for this bug, because I can create and destroy quick snapshots all day.

Actions #5

Updated by Kris Phillips over 1 year ago

This should probably be marked as Incomplete.

Actions #6

Updated by Jonas R over 1 year ago

FWIW: I get these errors whenever I (try to) delete a snapshot that is the parent snapshot of another clone. But deleting the children in turn, and then the parent snapshot. Would not result in error 21.

Also, as previous stated. The snapshot is acctually deleted. So the error is reporting false information.
6100, 22.09

Actions #7

Updated by Kris Phillips over 1 year ago

Jonas R wrote in #note-6:

FWIW: I get these errors whenever I (try to) delete a snapshot that is the parent snapshot of another clone. But deleting the children in turn, and then the parent snapshot. Would not result in error 21.

Also, as previous stated. The snapshot is acctually deleted. So the error is reporting false information.
6100, 22.09

Hello Jonas,

I recommend testing on 23.01. 22.09 is no longer an actively maintained version. Please install fresh on 22.05 and upgrade to the latest 23.01-BETA builds to verify if this is still a problem.

If you can recreate this, can you please provide step-by-step how you recreated the issue?

Actions #8

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Feedback
  • Target version changed from 23.01 to 23.05

Moving this ahead and marking that we need feedback here. It's still not clear how to reproduce this, and thus far nobody who has attempted to reproduce it has been able to replicate the error condition.

Actions #9

Updated by Marcos M over 1 year ago

  • Status changed from Feedback to Confirmed

I can reproduce this on 23.01.

  1. Click Create and use default as the source; save it.
  2. Click the duplicate icon on the new snapshot; save it.
  3. Click the delete icon on the snapshot created in step 1.
Actions #10

Updated by Christian McDonald over 1 year ago

Cool! Thanks for repro steps :)

Actions #11

Updated by Marcos M over 1 year ago

  • Has duplicate Bug #14224: Error when deleting Boot Environment that was the source for a clone added
Actions #12

Updated by Christian McDonald about 1 year ago

  • Target version changed from 23.05 to 23.09

Going to punt this to 23.09. Bigger fish to fry for 23.05 release.

Actions #13

Updated by Christian McDonald about 1 year ago

  • Category changed from Web Interface to Operating System
Actions #15

Updated by Jordan G 12 months ago

I was able to create a new boot environment, clone it and remove the original as described above on 23.09.a.20230710.1143 without encountering an error 21 message. The actual boot environment functions as expected also.

Actions #16

Updated by Kris Phillips 12 months ago

Tested on July 10th builds of 23.09. Following Marcos' steps, I'm not able to reproduce this bug, so looking fixed.

Actions #17

Updated by Christian McDonald 12 months ago

  • Status changed from Feedback to Resolved
Actions #18

Updated by Jim Pingle 11 months ago

  • Subject changed from Boot Environments GUI displays error to Error when deleting ZFS Boot Environment created from duplicate of non-default entry

Updating subject for release notes.

Actions

Also available in: Atom PDF