Project

General

Profile

Actions

Bug #14136

closed

Services Status page and Dashboard widget do not list the ``radvd`` service with certain static IPv6 configurations

Added by David Myers 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Services
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.05
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

After upgrading from 2.5.2 to 23.01 I noticed that radvd no longer appears in Services Status or the associated dashboard widget even though the process is enabled and running as configured. Assuming this change was not intended, I think there was an error introduced in #13446 and that this may be the fix:

--- pfsense-utils.inc.orig      2023-03-20 10:17:45.243876000 -0400
+++ pfsense-utils.inc   2023-03-20 10:17:05.850054000 -0400
@@ -1500,7 +1500,7 @@

        /* handle manually configured DHCP6 server settings first */
        foreach ($dhcpdv6cfg as $dhcpv6if => $dhcpv6ifconf) {
-               if (config_path_enabled("interfaces/{$dhcpv6if}")) {
+               if (!config_path_enabled("interfaces/{$dhcpv6if}")) {
                        continue;
                }

Actions #1

Updated by Jim Pingle 2 months ago

  • Assignee set to Jim Pingle
  • Target version set to 2.7.0
  • Plus Target Version set to 23.05
Actions #2

Updated by Jim Pingle 2 months ago

Took me a bit to find one but I was able to reproduce this on one system in my lab -- the others already showed it OK.

The inversion of that particular test is correct and does solve the problem.

Actions #3

Updated by Jim Pingle 2 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by David Myers 2 months ago

Jim Pingle wrote in #note-2:

Took me a bit to find one but I was able to reproduce this on one system in my lab -- the others already showed it OK.

I wasn't sure, but it looked like maybe you needed a static IPv6 LAN address to trigger this bug, so many users wouldn't see the issue.

The patch works for me.

Thanks!

Actions #5

Updated by Danilo Zrenjanin 2 months ago

  • Status changed from Feedback to Resolved

I replicated the issue on 23.01.

Re-tested the same scenario on 2.7.0.a.20230330.0600, and it worked fine. I am marking this ticket resolved.

Actions #6

Updated by Jim Pingle about 2 months ago

  • Subject changed from radvd missing from Services Status to Services Status page and Dashboard widget do not list the ``radvd`` service with certain static IPv6 configurations

Updating subject for release notes.

Actions

Also available in: Atom PDF