Project

General

Profile

Actions

Regression #14500

closed

PHP Error when viewing Traffic Graphs in ``iftop`` mode

Added by Jonathan Lee 10 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Graphs
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Default
Affected Version:
All
Affected Architecture:
SG-2100

Description

[22-Jun-2023 00:52:59 US/Pacific] PHP Fatal error: Uncaught TypeError: format_number(): Argument #1 ($num) must be of type int, string given, called in /usr/local/pfSense/include/www/bandwidth_by_ip.inc on line 172 and defined in /etc/inc/util.inc:2276
Stack trace:
#0 /usr/local/pfSense/include/www/bandwidth_by_ip.inc(172): format_number('', 2)
#1 /usr/local/www/bandwidth_by_ip.php(36): printBandwidth('lan', 'local', 'out', '', 'iftop')
#2 {main}
thrown in /etc/inc/util.inc on line 2276


Files


Related issues

Related to Bug #14236: PHP Error when viewing Traffic Graphs in ``iftop`` modeResolvedJim Pingle

Actions
Actions #1

Updated by Jim Pingle 10 months ago

  • Tracker changed from Bug to Regression
  • Subject changed from php errors with traffic graphing to PHP Error when viewing Traffic Graphs in ``iftop`` mode
  • Assignee set to Christian McDonald
  • Target version set to CE-Next
  • Plus Target Version set to 23.09

I had fixed this in #14236 but then it regressed when the function was rewritten in fd30ce6a3bddfbc88560952153dc4c2fdefbe341

Actions #2

Updated by Jim Pingle 10 months ago

  • Related to Bug #14236: PHP Error when viewing Traffic Graphs in ``iftop`` mode added
Actions #3

Updated by Jonathan Lee 10 months ago

@Jim Pingle

Thanks for looking into this. I appreciate all you do.

Actions #4

Updated by Lev Prokofev 9 months ago

Can't reproduce the issue on 23.05.1 and on 23.09-DEVELOPMENT (amd64)
built on Wed Jul 19 20:12:23 UTC 2023

Actions #5

Updated by Jim Pingle 8 months ago

  • Status changed from New to In Progress
  • Assignee changed from Christian McDonald to Jim Pingle
  • Target version changed from CE-Next to 2.8.0
Actions #6

Updated by Jim Pingle 8 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #7

Updated by Jordan G 7 months ago

testing with above changeset applied via system_patches package running 23.05.1, I am not seeing any crashes or php errors when using traffic graphs in iftop mode.

Actions #8

Updated by Jim Pingle 7 months ago

  • Status changed from Feedback to Resolved
Actions #9

Updated by Jonathan Lee 7 months ago

Thank you!!

Actions #10

Updated by Jim Pingle 6 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF