Project

General

Profile

Actions

Regression #14755

closed

Intermittent core dump in ``ndp`` when visiting ``diag_ndp.php``

Added by Jim Pingle 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Force Exclusion
Affected Version:
Affected Architecture:

Description

In certain cases when visiting diag_ndp.php the NDP table is empty and ndp has dumped core:

Sep  6 16:41:38 pfsense kernel: pid 44713 (ndp), jid 0, uid 0: exited on signal 11 (core dumped)

I cannot reproduce this reliably on the same system or on others on demand, it just happens every once in a while.

I have a core file here from a system running 23.09.a.20230905.0551.

While this seems likely to affect both CE and Plus dev snapshots, the only reports so far have been from Plus 23.09.


Files

ndp.full (98.6 KB) ndp.full Christian McDonald, 09/13/2023 06:28 PM
Actions #1

Updated by Rob A 9 months ago

Just checked and both ndp -an and ndp -na work via the CLI, so regression limited to the GUI. For me the issue is not intermittent.

<118>Bootup complete
<6>pid 54956 (ndp), jid 0, uid 0: exited on signal 11 (core dumped)
<6>pid 98799 (ndp), jid 0, uid 0: exited on signal 11 (core dumped)
<6>pid 36036 (ndp), jid 0, uid 0: exited on signal 11 (core dumped)
<6>pid 52178 (ndp), jid 0, uid 0: exited on signal 11 (core dumped)
<6>pid 79239 (ndp), jid 0, uid 0: exited on signal 11 (core dumped)
<6>pid 95436 (ndp), jid 0, uid 0: exited on signal 11 (core dumped)
<6>ng0: changing name to 'pppoe0'
pf_test6: kif == NULL, if_xname pppoe0
<6>ng0: changing name to 'pppoe0'

I also noticed this at the end of the CLI ndp table this time around:

Segmentation fault (core dumped)

Original thread:

https://forum.netgate.com/topic/182666/ndp-table-data-missing-gui

☕️

Actions #2

Updated by Jim Pingle 9 months ago

  • Project changed from pfSense Plus to pfSense
  • Category changed from Operating System to Operating System
  • Target version changed from 23.09 to 2.8.0
  • Plus Target Version set to 23.09
Actions #3

Updated by Christian McDonald 9 months ago

Attached is ndp built with debugging symbols for anyone who can reliably replicate this

mv /usr/sbin/ndp /usr/sbin/ndp.orig
mv ndp.full /usr/sbin/ndp
Actions #4

Updated by Christian McDonald 9 months ago

  • Status changed from New to In Progress
  • Assignee set to Christian McDonald
Actions #6

Updated by Marcos M 7 months ago

  • Status changed from Feedback to Resolved
Actions #7

Updated by Jim Pingle 7 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF