Project

General

Profile

Actions

Bug #14859

open

Config upgrade error: upgrade_config.inc:6135

Added by Steve Wheeler 5 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Upgrade
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
24.03
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:

Description

Upon restoring a config from pfSense 2.4.X or older:

Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /etc/inc/upgrade_config.inc:6135
Stack trace:
#0 /etc/inc/config.lib.inc(513): upgrade_202_to_203()
#1 /etc/rc.bootup(135): convert_config()
#2 {main}
  thrown in /etc/inc/upgrade_config.inc on line 6135

The config triggering this contained:

 <gres></gres>


Related issues

Related to Bug #14742: Several PHP errors in upgrade_config.incNewJim Pingle

Actions
Actions #1

Updated by Christopher Cope 5 months ago

  • Related to Bug #14742: Several PHP errors in upgrade_config.inc added
Actions

Also available in: Atom PDF