Project

General

Profile

Actions

Regression #14965

closed

Input validation prevents saving DHCPv6 Relay settings

Added by Danilo Zrenjanin 8 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DHCP Relay
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.09.1
Release Notes:
Default
Affected Version:
2.7.1
Affected Architecture:
All

Description

On the 23.09-RELEASE, DHCPv6 Relay won't start. Although the Upstream Servers field has a valid server address, it throws an error.

The error message:

The following input errors were detected:

The field Destination Server is required.

It worked fine on the previous version.


Files

Actions #1

Updated by Lev Prokofev 8 months ago

the same behavior,

tested on

Actions #2

Updated by Lev Prokofev 8 months ago

the same behavior,

tested on

    23.09-RELEASE (amd64)
built on Tue Oct 31 22:56:00 MSK 2023
FreeBSD 14.0-CURRENT

Actions #3

Updated by Kris Phillips 8 months ago

I can also verify this behavior.

Actions #4

Updated by Marcos M 7 months ago

  • Status changed from New to In Progress
  • Assignee set to Marcos M
  • Target version set to 2.8.0
  • Plus Target Version set to 24.03
Actions #5

Updated by Marcos M 7 months ago

  • Subject changed from ISC DHCPv6 Relay won't start to Input validation prevents saving DHCPv6 Relay settings
  • Status changed from In Progress to Pull Request Review
  • Affected Version set to 2.7.1
  • Affected Architecture All added
Actions #6

Updated by Marcos M 7 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #7

Updated by Danilo Zrenjanin 7 months ago

I tested the patch.

The error message "Destination Server is required" has been resolved, however, the service is still not starting.

Please check again.

Actions #8

Updated by Lev Prokofev 7 months ago

Tested the patch and service is able to start

Actions #9

Updated by Danilo Zrenjanin 7 months ago

  • Status changed from Feedback to Resolved

I tested again on a clean install and it indeed works fine.

I am marking this ticket resolved.

Actions #10

Updated by Jim Pingle 7 months ago

  • Target version changed from 2.8.0 to 2.7.2
  • Plus Target Version changed from 24.03 to 23.09.1
Actions

Also available in: Atom PDF