Project

General

Profile

Actions

Feature #2595

closed

Better hardware support for the Atoms (D2500, D2700, N2800)

Added by Vladimir Putin over 9 years ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
Start date:
08/14/2012
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:

Description

There has been a commit to the FreeBSD source which fixes the video corruption.

http://freshbsd.org/commit/freebsd/r237203

"On certain newer Intel Atom based motherboards, for instance the
D2500CC which I have, syscons in text-mode fails to show the expected
contents due to write errors into video-memory.

At least one of the causes is that we copy from syscons internal buffer
to the video memory with optimized bcopy(9) which uses >16bit operations.

Until now, 32bit and wider operations have always worked on the video
memory, but since I cannot find a single source which says that this
SHALL work, and since these chipsets/bugs are now out there, this
commit changes syscons to always use 16bit copies on i386 & amd64."

Actions #1

Updated by Ermal Luçi over 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Applied in changeset pfsense-tools:commit:2cce75c70fa831a4356184f88cefd6a3b65853c1.

Actions #2

Updated by Vladimir Putin over 9 years ago

FIXED for the D2500CC board, at least on x86 architecture.
Waiting confirmation for the x64 in the forum

Actions #3

Updated by Vladimir Putin over 9 years ago

kitdavis reported in forum, that for amd64 build problem is also solved.
http://forum.pfsense.org/index.php/topic,51661.0.html

Actions #4

Updated by Jim Pingle over 9 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF