Project

General

Profile

Bug #3432

PPPoE (WAN) reconnected, WAN does not updated

Added by Vladimir Putin about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
02/03/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

I am connected to ISP via PPPoE with dynamic IP. WAN is configured as PPPoE and this configuration was working about 200 days without any reboots. Today, running build "Jan 28 10:57:11 kernel: FreeBSD 8.3-RELEASE-p14 #1: Sat Jan 25 10:34:05 EST 2014" I have found that internet is lost on all clients connected to pf, I've tried to connect to pf and ping some www.neti.ee - success! So I've looked at logs and found that PPPoE successfully reconnected (last lines), reconnection caused by ISP maximum connection time is 8 days.
Feb 4 02:46:05 ppp: [wan] IFACE: Rename interface ng0 to pppoe0
Feb 4 02:46:05 ppp: [wan] IFACE: Up event
But... in system log there is no detection of wan changes, nothing at all at this time, but IP is changed and this is why internet connection on pf clients is lost.

History

#1 Updated by Vladimir Putin about 7 years ago

Ok, looks like it was due reported via forums apinger bug

Feb 5 06:30:00 apinger: alarm canceled: WAN_PPPOE(212.7.29.253) *** down ***
Feb 5 06:29:34 apinger: ALARM: WAN_PPPOE(212.7.29.253) *** down ***
Feb 4 19:16:29 apinger: Starting Alarm Pinger, apinger(9295)
Feb 4 19:16:18 apinger: No usable targets found, exiting
Feb 4 19:16:18 apinger: Starting Alarm Pinger, apinger(21611)
Feb 4 18:59:53 apinger: SIGHUP received, reloading configuration.
Feb 4 06:21:54 apinger: Starting Alarm Pinger, apinger(50367)
Feb 4 06:21:45 apinger: No usable targets found, exiting
Feb 4 06:21:45 apinger: Starting Alarm Pinger, apinger(20917)
Jan 28 10:57:15 apinger: No usable targets found, exiting
Jan 28 10:57:15 apinger: Starting Alarm Pinger, apinger(22391)
Jan 26 08:26:28 apinger: No usable targets found, exiting

It was not running since Jan 28 10:57:15 apinger: No usable targets found, exiting
Not reproducible on new builds. Should be fixed now

#2 Updated by Chris Buechler about 7 years ago

  • Category set to Interfaces
  • Status changed from New to Feedback

#3 Updated by Renato Botelho about 7 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF