Project

General

Profile

Actions

Bug #346

closed

Status > Wireless doesn't work

Added by Chris Buechler almost 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Wireless
Target version:
Start date:
02/08/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

status_wireless.php doesn't display anything, though list scan does:

  1. ifconfig ath0_wlan2 list scan
    SSID/MESH ID BSSID CHAN RATE S:N INT CAPS
    cmb 00:50:7f:9a:fd:68 1 54M -92:-96 100 EPS MESHCONF MESHCONF HTCAP RSN WME

Also not sure why it's wlan2, it's the only wireless card in the system.

Interface config:

               <opt2>
                        <descr>OPT2</descr>
                        <if>ath0</if>
                        <wireless>
                                <standard>11b</standard>
                                <mode>bss</mode>
                                <protmode>off</protmode>
                                <ssid>asdfasdf</ssid>
                                <channel>0</channel>
                                <authmode></authmode>
                                <txpower>99</txpower>
                                <distance/>
                                <wpa>
                                        <macaddr_acl></macaddr_acl>
                                        <auth_algs>1</auth_algs>
                                        <wpa_mode>1</wpa_mode>
                                        <wpa_key_mgmt>WPA-PSK</wpa_key_mgmt>
                                        <wpa_pairwise>CCMP TKIP</wpa_pairwise>
                                        <wpa_group_rekey>60</wpa_group_rekey>
                                        <wpa_gmk_rekey>3600</wpa_gmk_rekey>
                                        <passphrase/>
                                        <ext_wpa_sw></ext_wpa_sw>
                                </wpa>
                                <wep>
                                </wep>
                        </wireless>
                        <enable/>
                        <spoofmac/>
                </opt2>

Actions #1

Updated by Ermal Luçi almost 12 years ago

  • Status changed from New to Feedback
Also not sure why it's wlan2, it's the only wireless card in the system.
Because the index number is extracted from the assigned interface number for simplicity.
From that you can tell that this interface is assigned as OPT2.
Actions #2

Updated by Chris Buechler almost 12 years ago

  • Status changed from Feedback to Resolved

fixed

Actions

Also available in: Atom PDF