Project

General

Profile

Bug #4028

Wireless Obytes counter always 0

Added by Phillip Davis over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Operating System
Target version:
Start date:
11/19/2014
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

On an Alix 2D13 with WiFi card in it.
2.2-BETA (i386)
built on Sun Nov 16 14:10:12 CST 2014
FreeBSD 10.1-RELEASE

Traffic Graph (from Status menu or the widget) always shows 0 traffic out on the WiFi interface to clients. Traffic in from clients shows correctly.
Root cause seems to be:
$ifinfo = pfSense_get_interface_stats('ath0_wlan0');
var_dump($ifinfo);
array(11) {
["inpkts"]=>
int(926911)
["inbytes"]=>
int(80903838)
["outpkts"]=>
int(1464350)
["outbytes"]=>
int(0)
["inerrs"]=>
int(16)
["outerrs"]=>
int(412)
["collisions"]=>
int(0)
["inmcasts"]=>
int(9751)
["outmcasts"]=>
int(0)
["unsuppproto"]=>
int(0)
["mtu"]=>
int(1500)
}

outbytes is zero.

And outbytes is not appearing in 'ath0' either (just checked that in case it ended up in the wrong place):
$ifinfo = pfSense_get_interface_stats('ath0');
var_dump($ifinfo);
array(11) {
["inpkts"]=>
int(982945)
["inbytes"]=>
int(0)
["outpkts"]=>
int(1127117)
["outbytes"]=>
int(0)
["inerrs"]=>
int(22129)
["outerrs"]=>
int(0)
["collisions"]=>
int(0)
["inmcasts"]=>
int(0)
["outmcasts"]=>
int(0)
["unsuppproto"]=>
int(0)
["mtu"]=>
int(2290)
}

Ordinary interfaces are working fine, e.g vr0,vr1,vr2 and also VLAN devices like vr0_vlan50.

History

#1 Updated by Phillip Davis over 4 years ago

It is not a super-important thing, but there might be other device name combinations that have this issue also, or other interesting or more important cases where pfSense_get_interface_stats() or something underneath that is not quite right.

#2 Updated by Chris Buechler over 4 years ago

  • Category set to Operating System
  • Status changed from New to Confirmed

confirmed. The root of the issue is the Obytes counter on ath0 and ath0_wlanX is always 0. For instance:

# netstat -i -b -n -I ath0
Name               Mtu Network       Address              Ipkts Ierrs Idrop     Ibytes    Opkts Oerrs     Obytes  Coll
ath0              2290 <Link#4>      00:02:6f:21:ed:b6   828938 298892     0          0    64579     0          0     0

on the wlanX interfaces, the Link line shows 0 as well.

netstat -i -b -n -I ath0_wlan1
Name               Mtu Network       Address              Ipkts Ierrs Idrop     Ibytes    Opkts Oerrs     Obytes  Coll
ath0_wlan1        1500 <Link#9>      00:02:6f:21:ed:b6    45549     1     0    3245603    62485     1          0     0
ath0_wlan1           - fe80::202:6ff fe80::202:6fff:fe        0     -     -          0        4     -        344     -
ath0_wlan1           - 10.68.1.0/24  10.68.1.1              622     -     -      39545      105     -      20794     -

So that looks to be an ath driver issue of some sort.

#3 Updated by Chris Buechler over 4 years ago

  • Subject changed from Traffic Graph out shows zero for ath0_wlan0 device to ath Obytes counter always 0

#4 Updated by Chris Buechler over 4 years ago

  • Subject changed from ath Obytes counter always 0 to Wireless Obytes counter always 0

this actually applies to all wifi judging by the FreeBSD PR on the issue.
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=184626

#5 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2 to 2.2.1

#6 Updated by Chris Buechler about 4 years ago

  • Target version changed from 2.2.1 to 2.2.2

That FreeBSD PR got bumped recently, no patch available at this time.

#7 Updated by Chris Buechler almost 4 years ago

  • Target version changed from 2.2.2 to 2.2.3

#9 Updated by Ermal Luçi almost 4 years ago

  • Status changed from Confirmed to Feedback

Merged stack from HEAD with the fix on 2.3

#10 Updated by Phillip Davis almost 4 years ago

I am not clear - is the fix coming just in 2.3, or also in he 2.2.3 builds?

#11 Updated by Jim Thompson almost 4 years ago

Phil,

We need to sync the patch to the RELENG_2_2 branch. (This work is in progress, but not done.)

#12 Updated by Ermal Luçi almost 4 years ago

Merged even for 2.2.3 the patch.

#13 Updated by Phillip Davis almost 4 years ago

Fixed for me on Alix with WiFi card with pfSense-2.2.3-DEVELOPMENT-2g-i386-nanobsd-upgrade-20150610-1048.img.gz
Now the traffic graph shows believable out traffic from the WiFi interface when doing stuff from a WiFi client.

#14 Updated by Kill Bill almost 4 years ago

WFM as well.

#15 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

here as well

Also available in: Atom PDF