Project

General

Profile

Bug #4304

pfflowd non-functional on 2.2.x versions

Added by Jeroen Roovers over 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
High
Assignee:
Jeremy Porter
Category:
pfflowd
Target version:
-
Start date:
01/26/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:

Description

Jan 26 20:56:32 pfflowd40995: pfflowd listening on pfsync0
Jan 26 20:56:32 kernel: pfsync0: promiscuous mode enabled
Jan 26 20:56:34 pfflowd40995: Unsupported pfsync version 5, exiting

I was kind of expecting pfflowd to work after this 2.2 upgrade.

History

#1 Updated by Jeroen Roovers over 4 years ago

The Packages page reports version as:

0.8 pkg v1.0.2

#2 Updated by Didier Richard over 4 years ago

Hello

First, many big thanks to team and contributors who build and maintain pfSense.

It happens that pfflowd is still broken after upgrading pfSense to 2.2.1.
Same package version for pfflowd : 0.8 pkg v1.0.2, including after re-install.
I checked and no flow packet is received at collector side. It did work fine up to 2.1.5.

Surprisingly, pfflowd doesn't crash immediately, but 5 or 6 minutes after (re)starting the service.

From Status\System Log :

Mar 20 23:30:02 - pfflowd[29286]: pfflowd listening on pfsync0
Mar 20 23:30:02 - kernel: pfsync0: promiscuous mode disabled
Mar 20 23:30:02 - kernel: pfsync0: promiscuous mode enabled
Mar 20 23:36:49 - pfflowd[29286]: Unsupported pfsync version 5, exiting

Hope this will be resolved soon, for now I will stick to 2.1 to continue to have a look at traffic from netflow collector.

#3 Updated by Didier Richard about 4 years ago

Hello

as advised in the forum : https://forum.pfsense.org/index.php?topic=88441.0
I have uninstalled pfflowd package and switched to softflowd.
This has solved the issue, data appears back on the netflow collector.

#4 Updated by Jeremy Porter about 4 years ago

  • Assignee set to Ermal Luçi
  • Priority changed from Normal to High
  • Target version set to 2.2.3
  • Affected Version set to 2.2

Can we please get this fixed soon.

#5 Updated by Ermal Luçi about 4 years ago

  • Status changed from New to Feedback

Fix committed need to try with new binaries.

#6 Updated by Renato Botelho about 4 years ago

  • % Done changed from 0 to 100

Package 1.0.3 contains the fix

#7 Updated by Chris Buechler about 4 years ago

  • Target version deleted (2.2.3)

#8 Updated by Jim Pingle about 4 years ago

  • Status changed from Feedback to Confirmed
  • Assignee deleted (Ermal Luçi)

Opening this back up. Though pfflowd does not complain about the pfsync version, it does not produce any data.

#9 Updated by Chris Buechler about 4 years ago

  • Subject changed from pfSense 2.2 - pfflowd: Unsupported pfsync version 5, exiting to pfflowd non-functional on 2.2.x versions
  • % Done changed from 100 to 0
  • Affected Version changed from 2.2 to 2.2.x

given some period of time, it also goes nuts and starts logging like mad, to the extent its logging generates over 6 MB/sec of disk writes.

#10 Updated by Jeremy Porter over 3 years ago

  • Assignee set to Jeremy Porter
  • Target version set to 2.3

#11 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Closed
  • Target version deleted (2.3)

pfflowd is abandoned upstream, and would require a good deal of work to function on FreeBSD 10+. softflowd is available as an option

#12 Updated by Brian Candler about 3 years ago

Aside: Softflowd unfortunately doesn't let you specify the source interface/address for sending netflow packets (which pfflowd did)

Also available in: Atom PDF