Project

General

Profile

Actions

Feature #4351

closed

Allow to disable BOOTP in DHCP server

Added by Phillip Davis almost 7 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
DHCP (IPv4)
Target version:
Start date:
01/30/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:

Description

As suggested in forum: https://forum.pfsense.org/index.php?topic=80264.0

To prevent the possibility that a malicious or accidental use of bootp on the network could exhaust the DHCP address pool.

Actions #1

Updated by Jose Luis Duran over 5 years ago

I am also seeing BOOTP queries being served for captive portal users. The problem is that BOOTP leases do not have a maximum lease time by default and they eventually exhaust the pool.

As a workaround, I disabled BOOTP for the captive portal's DHCP pool.

For interfaces where you might need BOOTP, perhaps having the ability to set the dynamic-bootp-lease-length in the GUI could be another option?

Actions #3

Updated by Renato Botelho over 5 years ago

  • Status changed from New to Feedback
  • Assignee set to Renato Botelho
  • Target version changed from Future to 2.4.0
  • % Done changed from 0 to 100

Pull request has been merged. Thanks

Actions #4

Updated by Jim Pingle almost 5 years ago

  • Status changed from Feedback to Resolved

Works

Actions #5

Updated by Jim Pingle almost 5 years ago

  • Target version changed from 2.4.0 to 2.3.3
Actions

Also available in: Atom PDF