Project

General

Profile

Bug #4387

Installer does not offer choices for keymap, screenmap or video font

Added by Vincent Bentley over 4 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Installer
Target version:
Start date:
02/07/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:

Description

The 2.2 Release AMD64 CD Installer does not provide any choices for keymap, screenmap or video font. Only '(default)' can be accepted.

I have just confirmed that international keyboard choices are available and selectable on the 2.1.5 AMD64 CD Installer.

This issue has been seen before in #807.

Associated revisions

Revision e04de268 (diff)
Added by Renato Botelho about 3 years ago

Do not obsolete /usr/share/syscons, it should fix #4387

History

#1 Updated by Jeremy Porter about 4 years ago

  • Status changed from New to Confirmed
  • Assignee set to Jeremy Porter
  • Target version set to 2.2.2

This does not appear to be directly related to 801. The installer is intentionally configured to skip those steps. I'll look at what it takes to undo the step skipping.

#2 Updated by Chris Buechler about 4 years ago

  • Target version changed from 2.2.2 to 2.2.3

#3 Updated by Chris Buechler almost 4 years ago

  • Target version changed from 2.2.3 to 2.3

#4 Updated by Florent THOMAS almost 4 years ago

In the installer, it was possible to choose something else instead default. In the 2.2.3 no more keymap are available in the installer

#5 Updated by Renato Botelho about 3 years ago

  • Status changed from Confirmed to Assigned
  • Assignee changed from Jeremy Porter to Renato Botelho

#6 Updated by Renato Botelho about 3 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

Pushed a fix

#7 Updated by Chris Buechler about 3 years ago

  • Status changed from Feedback to Confirmed
  • Affected Version changed from 2.2 to 2.2.x
  • Affected Architecture deleted (amd64)

/usr/share/syscons/keymaps still seems to be empty, which leaves it with no list to select from. The video font and screenmap selections still also blank, though those could probably just be removed.

#8 Updated by Renato Botelho about 3 years ago

  • Status changed from Confirmed to Feedback

It was missing a change on src.conf to re-enable syscons during build.

#9 Updated by Jim Pingle about 3 years ago

  • Status changed from Feedback to Resolved

Works, all selections are populated with choices and appear to work (font changes once selected and so on)

Also available in: Atom PDF