Project

General

Profile

Bug #4482

IPsec on gateway group with VIPs not working

Added by Chris Buechler almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Very High
Assignee:
Ermal Luçi
Category:
IPsec
Target version:
Start date:
03/02/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:

Description

IPsec connections that are bound to a gateway group using VIPs end up omitted from ipsec.conf, and are missing their 500/4500/ESP firewall rules.

Associated revisions

Revision 29de629e (diff)
Added by Chris Buechler almost 5 years ago

Use the parent interface, not the _vip for interfaces_use. Part of Ticket #4482

Revision aeaa6143 (diff)
Added by Chris Buechler almost 5 years ago

Use the parent interface, not the _vip for interfaces_use. Part of Ticket #4482

Revision c406924f (diff)
Added by Chris Buechler almost 5 years ago

same change as previous commit, for IPv6. Ticket #4482

Revision d8e4918f (diff)
Added by Chris Buechler almost 5 years ago

same change as previous commit, for IPv6. Ticket #4482

Revision a115e2e1 (diff)
Added by Chris Buechler almost 5 years ago

Use get_failover_interface here to find appropriate interface. Ticket #4482

Revision 9c370fe6 (diff)
Added by Chris Buechler almost 5 years ago

Use get_failover_interface here to find appropriate interface. Ticket #4482

Conflicts:
etc/inc/ipsec.inc

History

#1 Updated by Chris Buechler almost 5 years ago

  • Status changed from New to Confirmed
  • Assignee changed from Chris Buechler to Ermal Luçi

seems fixed now, to Ermal for review.

#2 Updated by Chris Buechler almost 5 years ago

  • Status changed from Confirmed to Feedback

seems to be fixed, Ermal will review.

#3 Updated by Chris Buechler almost 5 years ago

  • Status changed from Feedback to Resolved

Ermal confirmed this.

Also available in: Atom PDF