Project

General

Profile

Bug #4522

ipsec mobile client not working on android

Added by ruben rpuserh about 4 years ago. Updated over 3 years ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
IPsec
Target version:
-
Start date:
03/14/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:
amd64

Description

Hi,
I had before pfsense 2.1.5 and ip sec on mobile clients was working fine. I reinstalled pfsense to ner version and i copyed all configs. But now i cannot connect from android. I can connect from ios, macos , shrew but android is vrochen

History

#1 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Feedback

pretty sure this is a problem on the Android side that's getting triggered. Android (at least some versions) suffers from the racoon NAT-D bug with aggressive+PSK. aggressive+RSA was necessary to work around where I saw that issue.

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Not a Bug

this is a bug in racoon on Android. Described here. https://wiki.strongswan.org/issues/255 also #4891

not a bug in anything we can fix.

Also available in: Atom PDF