Project

General

Profile

Bug #4592

FreeBSD 10.1-RELEASE-p6 signal handling problems with squid (FreeBSD bug 195802)

Added by Christopher Taylor over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
04/08/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.2
Affected Architecture:
All

Description

I've posted a short comment on the support forums, but here's the FreeBSD Bug Report: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=195802#c6

History

#1 Updated by Renato Botelho over 4 years ago

  • Status changed from New to Feedback
  • Target version set to 2.2.2
  • % Done changed from 0 to 100

2.2.2 is going to p9, what will have the fix

#2 Updated by Chris Buechler over 4 years ago

I don't see where that got committed to RELENG_10_1 Renato, you sure that's in there?

#3 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2.2 to 2.2.3

#4 Updated by Christopher Taylor over 4 years ago

So, no chance for a patch until 2.2.3? I'd like to contribute on the squid package for pfSense, but we can't rely on service squid stop until this signal problem is fixed.

#5 Updated by Chris Buechler over 4 years ago

yes, 2.2.2-RELEASE is already built. we can get that patch into 2.2.3 snapshots at some point after 2.2.2, probably within a few days.

#6 Updated by Christopher Taylor over 4 years ago

Okay, great! Will you be referencing this bug in the changelog so I'll know when it goes into the 2.2.3 snapshots?

#7 Updated by Chris Buechler over 4 years ago

  • Affected Version changed from 2.2.1 to 2.2

Yeah, we'll update this ticket then. If you could help confirm the issue fixed at that point, that'd be appreciated.

#8 Updated by Renato Botelho over 4 years ago

Chris Buechler wrote:

I don't see where that got committed to RELENG_10_1 Renato, you sure that's in there?

You are right, I misread it. We need to apply the patch on our kernel to get it done on 10.1

#9 Updated by Christopher Taylor over 4 years ago

I just wanted to bump this bug report: I tested with 2.2.2, and it still dumps core (as Chris mentioned above).

I'm happy to test 2.2.3 dailies as soon as they're available.

#10 Updated by Chris Buechler over 4 years ago

  • Category set to Operating System
  • Status changed from Feedback to Confirmed
  • Assignee set to Renato Botelho

#11 Updated by Renato Botelho over 4 years ago

  • Status changed from Confirmed to Feedback

I've backported revisions from stable/10 and applied on 2.2.x snapshots

#12 Updated by Christopher Taylor over 4 years ago

Just did a firmware update to the latest 2.2.3 snapshot and shutdown works. Looking forward to the full 2.2.3 release.

#13 Updated by Chris Buechler over 4 years ago

  • Status changed from Feedback to Resolved

thanks for confirming.

Also available in: Atom PDF