Project

General

Profile

Actions

Bug #4804

closed

PPPoE Restart won't update IPv6 routing table with gif

Added by Armin Tueting over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
-
Start date:
06/30/2015
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
Affected Architecture:

Description

Hello,

after rebooting pfSense 2.2.3

#netstat -6nr
Internet6:
Destination                       Gateway                       Flags      Netif Expire
default                           2001:xxx:xxxx:xxxx::1         UGS        gif0
::1                               link#7                        UH          lo0
2001:xxx:xx::x                    2001:xxx:xxxx:xxxx::1         UGHS       gif0
2001:xxx:xxxx:xxxx::1             link#13                       UH         gif0

after restarting PPPoE

#netstat -6nr
Internet6:
Destination                       Gateway                       Flags      Netif Expire
::1                               link#7                        UH          lo0
2001:xxx:xxxx:xxxx::1             link#13                       UH         gif0

I'm missing the default route for ipv6

Actions #1

Updated by Chris Buechler over 6 years ago

  • Status changed from New to Feedback

what type of v6 connectivity do you have? Looks like a HE.net or similar tunnel?

Did this work at any previous point?

Actions #2

Updated by Armin Tueting over 6 years ago

Chris Buechler wrote:

what type of v6 connectivity do you have? Looks like a HE.net or similar tunnel?

Connectitivity is made available through HE.net tunnel.

Did this work at any previous point?

Yes, it worked before! But, I can't tell you at which Version it stopped working...

Actions #3

Updated by Chris Buechler over 6 years ago

  • Subject changed from [PPPoE] Restart won't update IPv6 routing table to PPPoE Restart won't update IPv6 routing table with gif
  • Priority changed from Very High to Normal

Updated subject to I think a closer description. But I can't replicate it that much even. Whether via gif, or DHCP6, or static v6, with PPPoE, disconnecting and reconnecting PPPoE under Status>Interfaces puts the correct default v6 gateway back into place.

How are you restarting the connection that triggers this?

Actions #4

Updated by Armin Tueting over 6 years ago

How are you restarting the connection that triggers this?

I've written a script...

#!/bin/sh

# Command to reload wan interface
/usr/local/sbin/pfSctl -c 'interface reload wan' >/dev/null 2>&1 || exit 1

# Command to log this event
/usr/bin/logger -t ppp "PPPoE reset executed on WAN" 

exit 0

Actions #5

Updated by Jim Thompson over 6 years ago

  • Assignee set to Chris Buechler
Actions #6

Updated by Chris Buechler over 6 years ago

  • Target version deleted (2.2.4)

Still not replicable doing same. Doesn't seem to be anything wrong here. Maybe an edge case of some sort I'm not replicating.

Armin: could you get me a copy of your config? Can email to cmb at pfsense dot org with reference to this ticket.

Actions #7

Updated by Armin Tueting over 6 years ago

Chris Buechler wrote:

Armin: could you get me a copy of your config? Can email to cmb at pfsense dot org with reference to this ticket.

Send my config to your email address.

Actions #8

Updated by Chris Buechler over 6 years ago

thanks Armin. Emailed you back for feedback.

Actions #9

Updated by Armin Tueting over 6 years ago

Emailed you my findings.

Actions #10

Updated by Chris Buechler about 6 years ago

Armin: does this still happen for you on 2.2.5? I suspect the root cause here is #5297 which was fixed in 2.2.5.

Actions #11

Updated by Armin Tueting about 6 years ago

Chris: nop - I'm afraid! What logs do you need to troubleshoot?

Actions #12

Updated by Chris Buechler over 5 years ago

  • Assignee deleted (Chris Buechler)

Armin: you still seeing this on 2.3.1_5 (or newer)?

Actions #13

Updated by Armin Tueting over 5 years ago

Chris,

no, I''m afraid as I don't use pfSense anymore!

Actions #14

Updated by Chris Buechler over 5 years ago

  • Status changed from Feedback to Closed
  • Affected Version deleted (2.2.3)
  • Affected Architecture added
  • Affected Architecture deleted (i386)
Actions

Also available in: Atom PDF