Project

General

Profile

Bug #4823

Kernel Panic on the backup server on a master/backup CARP setup with pfSync enabled

Added by Bernardo Pádua about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
CARP
Target version:
-
Start date:
07/09/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.3
Affected Architecture:
amd64

Description

I'd been running two pfsense firewalls on a master/backup setup with CARP. It was running fine on the 2.1.x branch. Now, after I upgraded to 2.2.2 and also on 2.2.3 the backup machine is crashing after a few minutes running with a kernel panic "Fatal trap 12: page fault while in kernel mode". Only the backup will crash, the master will be Ok.

When the "Synchronize States" option under the "High Availability Sync" is disabled, the backup will not crash anymore, leading me to believe the issue is related to pfSync state synchronisation.

The hardware on both machines is nearly identical (same MBs, CPUs, etc). The only diference between the master and backup hardware is that the backup only has one ethernet port (HP board with intel chipset) with VLANs for each logical interface, while the master has an extra board with 4 extra ethernet ports (also with intel chipset), one for each interface, not needing the VLANs. I'm using a separate 'SYNC' interface only for pfSync, which, on the master runs on a separate cable and on the backup is on a VLAN.

My setup also uses Limiters and the Traffic Shaper, which had other Panic issues on the 2.2.0 and 2.2.1 versions.

crash report 1.txt (302 KB) crash report 1.txt Bernardo Pádua, 07/09/2015 04:40 PM
crash report 2.txt (162 KB) crash report 2.txt Bernardo Pádua, 07/09/2015 04:40 PM

History

#1 Updated by Jim Pingle about 4 years ago

  • Status changed from New to Duplicate

Duplicate of #4310

Also available in: Atom PDF