Project

General

Profile

Actions

Bug #4918

closed

DH groups 22-24 do not function

Added by Michael Newton about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
IPsec
Target version:
Start date:
08/04/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:
All

Description

The configuration generated when DH groups 22-24 is incorrect (the ike and esp attributes are incomplete.)

Pull request 1807, 1808 on Github will resolve the problem, tested on 2.2.4.

Actions #1

Updated by Jim Thompson about 6 years ago

  • Assignee set to Renato Botelho
Actions #2

Updated by Kill Bill about 6 years ago

Resubmitted as:

https://github.com/pfsense/pfsense/pull/1908 (master)
https://github.com/pfsense/pfsense/pull/1909 (RELENG_2_2)

Kindly merge obvious bugfixes before yet another round of conflicts caused by the bootstrap madness.

Actions #3

Updated by Renato Botelho almost 6 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Pull requestes have been merged

Actions #4

Updated by Chris Buechler almost 6 years ago

  • Status changed from Feedback to Resolved

all the DH group values confirmed working in 2.2.5

Actions

Also available in: Atom PDF