Project

General

Profile

Bug #5282

Alias system broken on edit

Added by Steve Beaver over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
10/07/2015
Due date:
% Done:

0%

Estimated time:

Description

https://forum.pfsense.org/index.php?topic=100494.0

  1. When inserting\editing a port or URL alias, it's possible to change netmask. It should be disabled, but currently it's disabled only if change alias type in edit window, not on new\edit alias.
  2. Alias description it's not shown in alias list grid
  3. Port alias aren't visible from rules, like in 2.2.x
  4. Host alias doesn't show correctly in rules

Associated revisions

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Resolved
  • Fixed JavaScript
  • Unable to reproduce
  • Misplaced return caused alias system to only process one type of alias per rule (host, port etc)
  • Same as 3

#2 Updated by Steve Beaver over 3 years ago

Further updated to support both src and dst.

elseif replaced with if since they are not mutually exclusive.

Also available in: Atom PDF