Project

General

Profile

Bug #5460

firewall_rules_edit.php masks not updating for IPv6

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Not a Bug
Priority:
Normal
Target version:
-
Start date:
11/16/2015
Due date:
% Done:

0%

Estimated time:

Description

Add a new firewall rule, change protocol to IPv6, change source or dest to "Network", and you only have 1-32 for the mask options.

History

#1 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

Testing this tonight I found that once I enter an IPv6 address in the network, the full range (1 -> 127) becomes available. 32 is still the value selected, however. You can then change it.

Does that correspond with what you see? Would it be sufficient to simply select 127 once the IPv6 address is detected?

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Not a Bug
  • Target version deleted (2.3)
  • Affected Version deleted (2.3)

True, didn't think about that, just replicated as described on the forum. This is fine, it updates correctly after typing in an IPv6 IP or network. Nothing needed here.

Also available in: Atom PDF